Skip to Content
0

Enhancement in LM03 - Screen exit issue

Apr 13, 2017 at 10:11 AM

109

avatar image

Hi Gurus,

I am making a change in the RF transaction LM03.

For that I have copied the Screen 102 of LMOB into 9102 of XLRF.

changed 9102 to Subscreen.Added a new sample text to the screen to differentiate the screen. Then activated the screen exit 840(

EXIT_SAPLLMOB_840) and 850 (EXIT_SAPLLMOB_850) as a new project.Note that I have not coded anything in this exit. Then I configured this new screen 9102 as variant 1 in the "Define Screen Management ".

When I execute LM03 it does not pickup the new screen. Instead it just show the old screen without the text added.

Do I need to code the 840/850 exits?

Please help.

Thanks and Regards,

Anoop

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Manish Kumar Apr 13, 2017 at 11:18 AM
0

Hi Anoop, check under user name (t-code LRFMD) what variant is defined


qogsx.png (5.9 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Manish,

It is Variant 1 in LRFMD for my user id

Does this needs to be 0?

Thanks and Regards,

Anoop

jwheb.png (13.9 kB)
0
Anoop Karunakaran Apr 14, 2017 at 07:53 AM
0

Hi All,

I could resolved this.

The logical screen was not 0102, it was 0100.

So the dummy screen was not 1102 it was 1100 and the exits to be activated are 800 and 810 instead of 840 and 850.

Now I can see the new screen.

But there is a new issue :-) , pressing enter after entering a TO does not do anything.

I have entered code in user exit to map the import and export parameters of the exit function modules. Is there any extra code required to move the screen field value of the Subscreen to the main screen?Please help

Thanks and Regards,

Anoop

Show 1 Share
10 |10000 characters needed characters left characters exceeded

after entering a TO does not do anything.

Depend on the coding very difficult to suggest you can run the code in debug mode and see what is failing
0