Skip to Content

crashes after migrating from PB 10.2 to 12.6

Hi community,

after migrating a larger project from PB 10.2 to PB 12.6 (4088) I get strange crashes:

- always when loading some dw's, just before the dw is displayed

- strange: sometimes the dw comes up, sometimes not (of course with same retrieval arguments)

- there is no further message, PB 12.6 crashes, also the build application.

- the dw's are loading by ODBC from MS SQL 2012

Any suggestions what I can do?

Thanks,

Bernhard

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    Apr 12, 2017 at 11:32 AM

    Maybe it is a platform specific problem. Win10 is officially not supported.

    https://help.sap.com/saphelp_pb126/helpdata/en/2f/13dbb6b578101492acdcee6892734f/frameset.htm

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 12, 2017 at 07:13 AM

    Try a newer build version of PB 12.6. In 4098 was a bug fix for a crash with grid dw. Newest build number is 4138.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 12, 2017 at 10:39 AM

    Hi René,

    thanks for your answer, I installed build 4138, no change, same crashes, at least running under Win10 (dw's ar tabular or freeform, not grid).

    But: the same application runs absolut stable under Win7!

    Any additional suggestions?

    Thanks,

    Bernhard

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 12, 2017 at 12:39 PM

    PowerBuilder 2017 by Appeon will support W10.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 12, 2017 at 12:35 PM

    Thanks for your information, but,

    I had to install build 4138 again, some dll's have been held open by the OS and the setup software couldn't replace them (I didn't get any errors about this!)

    So the build was not completed until now.

    In the meantime I see no more crashes and the application seems to be stable, hope this holds on!

    (Not a good message when PB 12.6 is not supporting W10. How can you use it these days?)

    Thanks for your help!

    Bernhard

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 12, 2017 at 04:41 PM

    Hi Bernard;

    FWIW: I am using PB versions 11.5.1, 12.1, 12.5.1 and 2017. They are all running under the same W10 instance with no issues against Oracle 11g, SA 17, ASE 16 & SS 2016.

    Note: PB 12.6 had a lot of issues with the initial release. So applying EBF's is certainly highly recommended. For PB 2017 from Appeon, we have incorporated the EBF's into our PB release from the onset of our development cycle. So you'll have those in PB 2017 GA coming in June.

    Regards ... Chris

    Appeon: Director, Developer Relations

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 13, 2017 at 06:14 AM

    Hi Chris,

    thanks for your information, I'm looking forward to PB 2017!

    Bernhard

    Add comment
    10|10000 characters needed characters exceeded