Skip to Content
0

WorkManager 6.4 : Standard push functionality not working

Apr 11, 2017 at 06:56 PM

193

avatar image

Dear All,

We have configured work manager 6.4.

The standard push functionality is not working for work orders and notification both.

We have checked the configuration guide and all the standard config are maintained.

Can anyone suggest me what possibly I might have missed.

Although I checked the SMP server log and I saw this below error.

Can this be an issue ? Or there is something which requires additional configurations.

Please guide

Thanks and Regards

Neha Mahanty

twww7.png (11.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Sravanthi Polu Apr 13, 2017 at 05:43 AM
0

Hi Neha,

Verify /n/syclo/admin - > Administration- > Server Management - > Select Mobile Application - >Check sever name,middleware Svr SerNo,Server URL(FQDN),Target Host(IP address of the system where SMP is installed).

Regards,

Sravanthi.

Share
10 |10000 characters needed characters left characters exceeded
Neha Mahanty Apr 13, 2017 at 06:44 AM
0

Hi Sravanthi,

Thank you !! I checked, these details are maintained in the system. Although the outbound trigger port is not maintained. Do I need to give that detail here, Can you confirm?

Regards

Neha


zj636.png (27.3 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

You only need to maintain the Local Outbound Trigger Port in that screen if your SMP server is listening on a port other than the default configured for your environment. By default it is set to 8282 out of the box.

If you leave the port at 0000 here it will use the default.

--Bill

0
Mark Pe
Apr 21, 2017 at 02:17 PM
0

Neha,

Hi. Normally the standard Push Port is stated in the Agentry.ini. This Push port has to match your picture above as shown with the * Port.

You may refer to:

https://launchpad.support.sap.com/#/notes/1996731

Hope this helps you out.

Best Regards,

Mark Pe

SAP Product Support

Share
10 |10000 characters needed characters left characters exceeded
Neha Mahanty Aug 30, 2017 at 09:44 AM
0

Dear All,

This forum link was not closed, hence I am asking the question again.

The push functionality was working fine , Work order : Assignment type = 1 and Notification : Assignment type = 1

Now again it stopped working and I am not able to track whats missing coz I did not changed the configurations.

I can see the push triggers as the entry is present in all the required ECC tables. it just do not reaches the client ..

Does the port 8282 has to be opened from client to SMP server also ?

Please advice.

Many thanks in advance

Best Regards

Neha Mahanty

Show 2 Share
10 |10000 characters needed characters left characters exceeded

No the clients do not need access to pot 8282. That port needs to be open on the SMP server to receive the push notification from the backend ECC system.

--Bill

0

Hi Bill,

Thank you !! I guess some setting in our landscape needs to be checked again. I shall review the settings again.

Best Regards

Neha Mahanty

0