Skip to Content
0

PDF Problem

Apr 11, 2017 at 05:05 PM

222

avatar image

Hi,

We recently installed SP 19 for Visual Studio 2015 taking us up to v.13.0.19.2312. Exporting to PDF now has an issue with fonts. Notice how the letter t is now tt and we have overlapping characters.

We upgraded from v.13.0.16.1954 and the export was working properly. After upgrading the format changed. Running on Windows 2012 terminal server. I checked the date and version of crxf_pdf.dll January 21, 2017 version 13.0.19.2312.

The print preview looks fine, it's only to PDF that is having an issue. We originally found it on our production server but have since tested in Visual Studio on our DEV machine as well. Both machines were upgraded at the same time.

Has anyone else found this problem with this version?

Thanks,

Brian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Dell Stinnett-Christy Apr 12, 2017 at 01:53 PM
0

There is a registry setting that may work.

In either of the following:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0 - (on 64 bit OS)
  • HKEY_CURRENT_USER\Software\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0

go to or create ...\Crystal Reports\Export\PDF.

Then create the key UseCustomEncoding with a value type of DWord and a value of 0

-Dell

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Dell,

The registry entry appears to be working. I tested it on our DEV and Test servers and so far the PDF are holding their formatting.

Thanks,

Brian

0
Ido Millet Apr 11, 2017 at 05:25 PM
0

Font is Calibri?

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Why yes it is. Why do you ask?

Brian

0

Just did a search for Calibri and see it's a known issue.

Well shoot. All of our reports use Calibri because it's the default font in Office. So, we're going to have to change 200+ reports?

Brian

0