Skip to Content
0

Disp+work.exe starting and going down after sometime

Apr 11, 2017 at 07:14 AM

263

avatar image
Former Member

Dear,

Yesterday after the restart one of our sap server which is in windows cluster is not starting the sap application, the disp+work.exe is going down after sometime.

Sapstartsrv.log

--------------------------------------------------- trc file: "sapstartsrv.log", trc level: 0, release: "721" --------------------------------------------------- pid 2664 [Thr 5280] Mon Apr 10 16:09:42 2017 SAP HA Trace: SAP Microsoft Cluster library '721, patch 600, changelist 1613799' initialized CCMS agent initialization: WARNING: cannot recognize instance type, checking profile parameter "system/type". CCMS agent initialization for instance type ABAP: return code 0. CCMS agent start: return code 0. Initializing SAPControl Webservice Starting AutoRestart thread Copying E:\usr\sap\PRD\ERS10\exe\sapstartsrv.exe to E:\usr\sap\PRD\ERS10\exe\sapstartsrv.exe.new AutoRestart thread started, version check is enabled SapSSLInit failed => https support disabled Starting WebService Named Pipe thread Starting WebService thread Webservice named pipe thread started, listening on port \\.\pipe\sapcontrol_10 Webservice thread started, listening on port 51013 AWQAF\sapeng is stopping SAP System at 2017/04/11 8:48:43 SAP HA Trace: FindClusterResource: SAP resource not found [sapwinha.cpp, line 356] SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_NOT_CLUSTERED [sapwinha.cpp, line 936] AWQAF\sapeng is starting SAP System at 2017/04/11 8:48:53 SAP HA Trace: FindClusterResource: SAP resource not found [sapwinha.cpp, line 356] SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_NOT_CLUSTERED [sapwinha.cpp, line 936] [Thr 8476] Tue Apr 11 08:49:03 2017 sapstartsrv executable has changed only in timestamps, but is still the same version. Skipping restart

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Apr 11, 2017 at 09:01 AM
1

Dear Yatin,

The issue is solved by our server team, cluster service was not connecting to sap, they did the configuration for connectivity and the application is working fine now.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 11, 2017 at 07:40 AM
0

Hello,

Have you verified the nodes. Both the application and database should be on the same node while starting up the system.

Also provide dev_disp log from the work directory.

Please also check SAP note 1929468 and check if the same is relevant to your issue.

Regards,

Yatin

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 11, 2017 at 07:54 AM
0

Dear Yatin,

--------------------------------------------------- trc file: "dev_disp", trc level: 1, release: "721" --------------------------------------------------- sysno 01 sid PRD systemid 562 (PC with Windows NT) relno 7210 patchlevel 0 patchno 600 intno 20020600 make multithreaded, Unicode, 64 bit, optimized profile \\SAPPRDCLUSTER\sapmnt\PRD\SYS\profile\PRD_D01_AWQ-ERPPRD2 pid 8056 kernel runs with dp version 141000(ext=122000) (@(#) DPLIB-INT-VERSION-141000-UC) length of sys_adm_ext is 592 bytes *** SWITCH TRC-HIDE on *** ***LOG Q00=> DpSapEnvInit, DPStart (01 8056) [dpxxdisp.c 1317] shared lib "dw_xml.dll" version 600 successfully loaded shared lib "dw_xtc.dll" version 600 successfully loaded shared lib "dw_stl.dll" version 600 successfully loaded shared lib "dw_gui.dll" version 600 successfully loaded shared lib "dw_mdm.dll" version 600 successfully loaded shared lib "dw_rndrt.dll" version 600 successfully loaded shared lib "dw_abp.dll" version 600 successfully loaded shared lib "dw_sym.dll" version 600 successfully loaded shared lib "dw_aci.dll" version 600 successfully loaded rdisp/softcancel_sequence : -> 10,15,-1 use internal message server connection to port 3900 rdisp/dynamic_wp_check : 1 rdisp/calculateLoadAverage : 1 Tue Apr 11 10:50:58 2017 *** WARNING => DpNetCheck: NiAddrToHost(1.0.0.0) took 4 seconds ***LOG GZZ=> 1 possible network problems detected - check tracefile and adjust the DNS settings [dpxxtool2.c 6540] MtxInit: 30000 0 0 DpSysAdmExtInit: ABAP is active DpSysAdmExtInit: VMC (JAVA VM in WP) is not active display_tcp_ip:0 Set Check Logoff Flags to 0x0 DpIPCInit2: write dp-profile-values into sys_adm_ext DpIPCInit2: start server >AWQ-ERPPRD2_PRD_01 < DpShMCreate: sizeof(wp_adm)103328(2296) DpShMCreate: sizeof(tm_adm)57644816(28808) DpShMCreate: sizeof(wp_ca_adm)160000(64) DpShMCreate: sizeof(appc_ca_adm)160000(64) DpCommTableSize: max/headSize/ftSize/tableSize=2000/16/5568064/5568080 DpShMCreate: sizeof(comm_adm)5568080(2768) DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0 DpShMCreate: sizeof(slock_adm)0(296) DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0 DpShMCreate: sizeof(file_adm)0(80) DpShMCreate: sizeof(vmc_adm)0(2160) DpShMCreate: sizeof(wall_adm)(416064/352496/64/192) DpShMCreate: sizeof(gw_adm)48 DpShMCreate: sizeof(j2ee_adm)3952 DpShMCreate: SHM_DP_ADM_KEY(addr: 0000000010720050, size: 64423088) DpShMCreate: allocated sys_adm at 0000000010720060 DpShMCreate: allocated wp_adm_list at 00000000107230D0 DpShMCreate: allocated wp_adm at 00000000107232C0 DpShMCreate: allocated tm_adm_list at 000000001073C670 DpShMCreate: allocated tm_adm at 000000001073C6C0 DpShMCreate: allocated wp_ca_adm at 0000000013E35DE0 DpShMCreate: allocated appc_ca_adm at 0000000013E5CEF0 DpShMCreate: allocated comm_adm at 0000000013E84000 DpShMCreate: system runs without slock table DpShMCreate: system runs without file table DpShMCreate: allocated vmc_adm_list at 00000000143D3660 DpShMCreate: system runs without vmc_adm DpShMCreate: allocated gw_adm at 00000000143D3710 DpShMCreate: allocated j2ee_adm at 00000000143D3750 DpShMCreate: allocated ca_info at 00000000143D46D0 DpShMCreate: allocated wall_adm at 00000000143D4760 DpCommAttachTable: attached comm table (header=0000000013E84000/ft=0000000013E84010) DpSysAdmIntInit: initialize sys_adm rdisp/test_roll : roll strategy is DP_NORMAL_ROLL dia token check not active (20 token) MBUF state OFF DpCommInitTable: init table for 2000 entries DpRqQInit: keep protect_queue / slots_per_queue 0 / 2001 in sys_adm rdisp/queue_size_check_value : -> on,50,30,40,500,50,500,80 EmInit: MmSetImplementation( 2 ). MM global diagnostic options set: 0 <ES> client 0 initializing .... <ES> EsILock: use Mutex for locking <ES> InitFreeList <ES> block size is 4096 kByte. <ES> Info: em/initial_size_MB( 60525MB) not multiple of em/blocksize_KB( 4096KB) <ES> Info: em/initial_size_MB rounded up to 60528MB Using implementation view <EsNT> Using memory model view. <EsNT> Memory Reset disabled as NT default Tue Apr 11 10:50:59 2017 <ES> 15131 blocks reserved for free list. ES initialized. mm.dump: set maximum dump mem to 192 MB mm.dump: set global maximum dump mem to 192 MB EsRegisterEmCheck: Register EmGetEsHandles at 0000000140A48920 DpVmcSetActive: set vmc state DP_VMC_NOT_ACTIVE MPI: dynamic quotas disabled. MPI init: pipes=4000 buffers=1279 reserved=383 quota=10% rdisp/http_min_wait_dia_wp : 1 -> 1 ***LOG CPS=> DpLoopInit, ICU ( 4.0.1 4.0.1 5.1) [dpxxdisp.c 1703] ***LOG Q0K=> DpMsAttach, mscon ( SAPPRDCLUSTER) [dpxxdisp.c 12940] MBUF state LOADING DpStartStopMsg: send start message (myname is >AWQ-ERPPRD2_PRD_01 <) DpStartStopMsg: start msg sent to message server o.k. CCMS: Initialized CCMS Headers in the shared monitoring segment. CCMS: start to initalize 3.X shared alert area (first segment). DpMBufHwIdSet: set Hardware-ID ***LOG Q1C=> DpMBufHwIdSet [dpxxmbuf.c 1296] MBUF state ACTIVE DpWpBlksLow: max wp blocks in queue is 2000 (80 %) MBUF component UP DpMsgProcess: 2 server in MBUF DpAppcBlksLow: max appc blocks in queue is 1250 (50 %) Tue Apr 11 10:53:37 2017 DIA water mark reached (>30)

Share
10 |10000 characters needed characters left characters exceeded