Skip to Content
0

SAP BODS Designer connection to ECC SAP WebService (HTTPS)

Apr 10, 2017 at 08:30 AM

306

avatar image

Hello there!

We've got Suse server with BO installed (BO and DS). When I create SOAP connection in DS Designer it parses WSDL and I am able to get metadata. But when I try to execute Job it fails, doesn't see server at all. I suppose I need to do something on server side of BODS, but don't understand what.

// this WSDL work well on openSuse server in another project (Python).

Regards, Yury

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Arun Sasi Apr 10, 2017 at 02:44 PM
0

Hi

What is the error message which you get. Kindly post the error message

Regards

Arun Sasi

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Arun!

There is no response for the web service <ZpmMbSetMeasures6>. Ensure that the network, web server, and service are running properly. Also ensure that the service client call time out is set properly.

And nothing else.

Yury

0

Hi Yury,

As suggested by Doug, please follow the steps in
SAP Note 1771712.

Regards

Arun Sasi

0
Doug Staub
Apr 10, 2017 at 04:13 PM
0

Hi Yury,

Since you are trying to use https, make sure you have followed the steps in Knowledge Base article:

https://launchpad.support.sap.com/#/notes/1771712

These steps will need to be followed to successfully access an https web service. Thanks.

Doug

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Doug!

Our Basis team made part of their work, I made changes in connection for Axis2/c:

/home/biadmin/BI41/dataservices/ext/webservice-ies

but no luck, same error as before:

There is no response for the web service <ZpmMbEcho>. Ensure that the network, web server, and service are running properly.

Regards,

Yury

0

Hi Yuriy,

To further troubleshoot the issue I would suggest enabling axis2 logging and test the job. You don't mention what version of Data Services you are on. If you are on a version earlier than DS 4.2 SP2 patch2, refer to KBA 1820023 for steps to create the log. If you are on 4.2 SP2 patch2 or later, refer to KBA 2178417 for steps to enable the logging. Once you run the job and have the log, check it for clues that might point you towards the problem. Thanks.

Doug

0

Hello there Doug!

Thanx! we turned on logs and also tried to test http request, not only https. it looks like Data Services got some troubles on creating connection at all + reading certificates for ssl..

HTTP

[Mon May 29 16:05:00 2017] [debug] addr_out_handler.c(133) No action
present. Stop processing addressing
[Mon May 29 16:05:00 2017] [debug] http_transport_sender.c(246) ctx_epr:http://10.5.7.26:21602/adeptstorage.cgi
[Mon May 29 16:05:00 2017] [debug] http_transport_sender.c(805) using axis2 native http sender.
[Mon May 29 16:05:00 2017] [debug] http_sender.c(416) msg_ctx_id:urn:uuid:6c4360d0-446f-1e71-2c7b-005056a87cad
[Mon May 29 16:05:03 2017] [error] http_client.c(246) Error creating a socket. Most probably error returned by OS
[Mon May 29 16:05:03 2017] [error] http_client.c(247) Socket Creation failed.
[Mon May 29 16:05:03 2017] [error] http_client.c(552) client data stream null or socket error for host 10.5.7.26 and 21602 port
[Mon May 29 16:05:03 2017] [error] http_client.c(556) A read attempt(HTTP) for the reply without sending the request
[Mon May 29 16:05:03 2017] [error] http_sender.c(1381) status_code < 0
[Mon May 29 16:05:03 2017] [error] engine.c(179) Transport sender invoke failed

AND HTTPS:

[Mon May 22 16:39:49 2017] [debug] http_sender.c(416)
msg_ctx_id:urn:uuid:201fd984-3ef4-1e71-294c-005056a87cad
[Mon May 22 16:39:49 2017] [info] [ssl client] Client certificate chain filenot specified
[Mon May 22 16:39:49 2017] [error] ssl/ssl_utils.c(112) [ssl client] Loading CA certificate failed, ca_file is /home/biadmin/BI41/dataservices/ssl/trusted_certs
[Mon May 22 16:39:49 2017] [error] ssl/ssl_stream.c(97) Error occurred in SSL engine
[Mon May 22 16:39:49 2017] [error] http_client.c(295) Data stream creation failed for Host msk-sap-wsd.ad.ies-holding.com and 8002 port
[Mon May 22 16:39:49 2017] [error] http_client.c(552) client data stream null or socket error for host msk-sap-wsd.ad.ies-holding.com and 8002 port
[Mon May 22 16:39:49 2017] [error] http_client.c(556) A read attempt(HTTP) for the reply without sending the request
[Mon May 22 16:39:49 2017] [error] http_sender.c(1381) status_code < 0

Any Ideas about http?

Regards,

Yury

0