Skip to Content
0

GCP SAP HANA EXPRESS - XSJS

Apr 08, 2017 at 03:45 PM

196

avatar image

Hi, I was trying a simple XSJS in SAP HANA express hosted in Google Cloud platform.

While accessing the XSJS file, I am getting 404 Not Found error message.

XS engine is up and running.

untitled.png (67.8 kB)
untitled.png (19.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Lucia Subatin
Apr 08, 2017 at 06:57 PM
0

Hi Jeet, Is the first part of your URL https?

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Also, have you tried running it from the "Run As.." from HANA Studio? That would help with https/port/path problems

testxsjs.png (30.3 kB)
0

Hi Lucia,

I am trying from HANA Studio only, the way you have mentioned.

Https is not been added to the URL when I try to run from HANA Studio. Only the port and path in google chrome

In Google chrome browser there is no HTTP/HTTPS :

In IE there is HTTP :

I tried changing to HTTPS in IE, I am getting below message. Checked TLS 1/1.1/1/2 are turned on in the network settings.

In Google chrome, using HTTPS i am getting error response, "This site can't provide secure connection" .

untitled.png (5.0 kB)
untitled.png (11.4 kB)
untitled.png (44.8 kB)
0

Does the first part of your URL point at an IP or the name of a host? If the latter, what is the name of the host?

Also, can you right-click on the system from the System tab, go to application lifecycle management -> Home ? It should also open an XS site. Is the same happening?

0

Hi Lucia,

URL is pointing to IP. External IP from GCP.

System->Application lifecycle management->Home is also having the same "404-Not found" error response message.

0

System->Application lifecycle management->Home

untitled.png (23.2 kB)
0
If this is the Launcher version in GCP, have you installed XS tooling? https://www.sap.com/developer/how-tos/2016/10/hxe-xs-tooling.html Despite the XS splash screen, the version from the GCP launcher is server-only.
0

Thanks Lucia. Followed the steps in the above link and the issue is resolved.

0
Florian Pfeffer
Apr 08, 2017 at 04:52 PM
0

How does your application structure look like.

Do you have

  • an .xsapp file (with content { })?
  • an .xsaccess file with the exposed property set, so that an access is possible ({ "exposed": true })?

Regards,
Florian

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Yes .xsapp and .xsaccess files are available. Its get created along with XS project. I have checked it has the content as mentioned .

0

Can you share a screenshot of your project structure?

0

Hi Florian, Project structure

capture.png (14.1 kB)
0

Hm, your xsjs file is called "HelloWorld.xsjs". In the URL above it seems you have a typo -> "HellowWorld.xsjs".

0

I was trying different option and shared wrong SS. Below is the SS with HelloWorld.xsjs having the same issue.

untitled.png (26.2 kB)
0