Skip to Content

Packaging Condition Record didn't fetch "Ship From" value in EWM

Hi Experts,

I have created packaging spec. for Inbound delivery (delivery type INB, doc. category PDI) created with /SCWM/PRDI. When I chose Inbound Delivery > Follow on Function > Pack from menu path, and there I hit the icon for 'Pack Automatically' nothing happens. To find out the Packaging Determination log I run the T.code /SCWM/PSLOG where it's showing 'Condition Record Not Found'. To see the details, I selected the Condition Type ZIND (a custom condition type ZIND assigned to Standard Condition table SAPIBD01, in config for packaging specification) and click on 'Complete List' icon. It's showing as follows -.

PACK_LOCID = Value displayed (in 'Raw' data format)

PACK_MATID = Value displayed (in 'Raw' data format)

PACK_SHIP_FROM = showing blank

Though I have maintained all these values against my product, via the t.code for 'Condition Maintenance' [i.e. t.code /SCWM/PSCT6], for my custom condition type ZIND.

Any idea why particularly the value 'Ship From' is not showing anything ?

Is it because I have created a custom Condition ZIND Type instead of standard condition type 0IBD ?

P.S. - The delivery document has the same value of 'Ship From' as maintained in the transaction /SCWM/PSCT6.

Also, I have assigned Packing determination Procedure to in the config set up for Delivery Type INB - PDI combo.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Apr 10, 2017 at 06:32 AM

    Hi,

    "Also, I have assigned Packing determination Procedure to in the config set up for Delivery Type INB - PDI combo."

    Good. But have you also maintained the proper role in the field "Partner Role"? Because if the partner is not used, I would suppose this is missing.

    Brgds

    Juergen

    ---
    Want to learn EWM?
    Check for EWM courses @ https://training.sap.com/curriculum/scm_ewm
    Get a SAP Learning Hub Subscription: https://training.sap.com/shop/learninghub

    And it is EWM. NOT eWM - Duh!

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 11, 2017 at 04:47 AM

    Hi Jürgen,

    are you sure that Standard is considering this field at all? At least on Outbound side (packaging specification Determination in Course of packing Profile during WOCR) I know that SHIP-TO is not being considered by Standard although it is part of Standard condition table (Need to implement Badi in order to have the field filled during runtime). You can check sap note 2340827 for further information.

    Regards,

    Hendrik

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 11, 2017 at 07:13 AM

    Hello Hendrik,

    "are you sure that Standard is considering this field at all?"

    Yes, I am. Just tried, and it worked perfectly.

    "I know that SHIP-TO is not being considered by Standard although it is part of Standard condition table (Need to implement Badi in order to have the field filled during runtime). You can check sap note 2340827 for further information."

    Thanks for the note, hadn't seen that one before. Well, I tried what it explains there, and indeed, the ship-to-party is not considered during warehouse order creation. But why is that? The note describes the sympton and the reproduction of the issue allright (although I hope you never assign an additional field to an existing, created from a BC set, condition table...), but the description of the cause is ... ah, I better don't write what I think about it. WHY does it not work when you use the three mentioned fields in a condition table in the described issue? Because it is during WAREHOUSE ORDER CREATION. And of course NONE of the mentioned fields (Ship to, shipping condition, or material) is part of the warehouse order. And that is the reason why the BAdI is required.

    Brgds

    Juergen

    Add comment
    10|10000 characters needed characters exceeded