Skip to Content
-2

Finding deletion log for Function group

Apr 07, 2017 at 09:08 AM

157

avatar image
Former Member

Hello all,

I face an issue :

The FM can be display in SE37 but when i jump to it's function group by navigation from SM37 and i got message : Function group XXX does not exist, Message No. EU895

i check the function group in SE80 and it not available also not available.

i am not sure that it be deleted by someone else or not. Please advice me any way to find out the log for function group.

Thanks in advance.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Horst Keller
Apr 08, 2017 at 09:10 AM
0

A function group consists of a set of programs, the master program and a bunch of includes. For whatsoever reasons, most probably wrong transports, there seems to be an inconsistent state in your system. Your function module - residing in one include - cannot be active without it's master program SAPLfugr. You must look for a system where the function group is complete and transport it as a whole.

B.t w., did you check in SE38 if SAPLfugr is there? If yes, activating it might help. If not, see above.

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Horst,

Thanks for your reply.

program SAPLfugr is existed and i can active program and also function module.

The TR of FM include all : Fugr, FM, report program SAPL....

But when i traced the log of this TR and received no log... I will ask basis for more checking this TR.

0

But if SAPLfugr is there and active, you shouldn´t have any problem at all ...

0
Former Member
Horst Keller

You're correct that the FM is ok because the it's main program was already actived. The issue came from the TR be import from another system to our system that missing the Fugr object that why i could not check it in SE80.

0
Kiran K Apr 07, 2017 at 10:09 AM
0

John,

Did you check if there are any TRs for that function group using

SE03 >>Search for Objects in Requests/Tasks

Tick the 2nd checkbox with R3TR FUGR "give the function group name".

You will be able to see the TRs against that FG.

K.Kiran.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Kiran,

Thanks for your reply, i tried to check if any modify and released TR in SE03 before that but no object was found.

but if i use se37 to view 1 FM in that FG then i can see the code.

Then i tried to find out the version of FM and i saw the TR with many FM and without FG.

I thought this TR was transfered from another system and missed some object but when i view the log of TR and see not navigate to any system..

0