Skip to Content

Deployement Error in webdynpro apps on sneak preview 2004s

Hi all,

I installed Sneak Preview 2004s with SP 7 on my Computer(having 2 GB Ram and Win XP professional 2002 with sp 2), as this installation is being done on J2SDK 1.4.2_09 version, so portal is running fine on local host.

But when i m trying to Deploy my simple webdynpro application on this local Web AS i m getting the error that urs SDM Host is not correctly configured.

Also, i have already done the server configuration by windows--> preferences --> SAP J2EE Engine.

If any one knows abt this issue plz help me.

Thanks

Dheerendra shukla

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 06, 2006 at 09:08 AM

    Hi Dheerendra,

    Are you able login to Visual Administrator?.

    check whether your able login via remotegui.bat(SDM)? could you please elborate status.

    Try opening Visual Admin if your not able to login with username(administrator) and password. Problem with NWD2004s do the following steps.

    C:\usr\sap\J2E\JC01\j2ee\configtool->configtool.bat->open it

    1. Click on Secure store

    2. Right you will find :

    admin/password/J2E->retype your admin passowrd which you gave during installation=>SAVE properly

    Restart the server and try login visual admin

    If your administrator user is locked means see this link for unlocking user.

    nw-2004s-inst-admin-locked

    Regards, Suresh KB

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Suresh,

      I tried as per ur answer and deploy my application through SDM GUI, But i got the following error.

      =========================================================

      Deployment started Mon Nov 06 15:41:48 IST 2006

      =========================================================

      Starting Deployment of TravelRequest

      The SDM will now start SAP Web AS Java instance processes in order to perform online deployment. After that the deployment will proceed.

      It could take some time, so please be patient.

      Aborted: development component 'TravelRequest'/'local'/'LOKAL'/'0.2006.11.06.13.24.06':

      SDM could not start the J2EE cluster on the host systech-sap94! The online deployment is terminated. There is no control instance running in the cluster:|Name:JM_T1162795564937_0_systech-sap94 |Host:systech-sap94 |State:5|HostAddress:192.168.1.76|Please check if there are running cluster instances.

      (message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.performAction(DeploymentActionTypes).STARTUP_CLUSTER)

      Deployment of TravelRequest finished with Error (Duration 6453 ms)

      Even when i deploy the same application to my Remote sever, it not only deploy but run successfully through the webdynpro IDE..

      Thanks

      Dheerendra