Skip to Content
avatar image
Former Member

Java WD drop-downs not working correctly

Hi all:

My company is upgrading from NW 7.0 2004s to NW 7.4 SP14. We've just recently gotten over a big challenge getting applications running GUI for HTML trans-iViews & Java WD applications requiring Classic Event Framework to live on the same portal server by using the following settings:

- Under Portal Content > Portal Users > Standard Portal Users > Classic Framework Page > Browser Document Mode, the Browser Document Mode setting is now “IE=EDGE”.

- Under each SAPGUI Report’s trans-iView, the ‘Default Document Rendering Mode’ is set to ‘Standard’.

We've done this because my company requires us to standardize on Internet Explorer 11, both on Windows 7 & Windows 10. Unfortunately, this has caused a number of serious Java WD UI issues (pictures attached), such as:

- drop-down boxes are now only 1-3 rows visible when selected, no matter how many values they contain, making it difficult to select, see and scroll between all possible values.

- input text boxes now overlap their description labels instead of being painted adjacent to them.

- within tables, 1st row dropdown values are the only ones ever displayed, even when selecting another row’s dropdown values, including when that lower row is the lead selection.

After reading https://wiki.scn.sap.com/wiki/display/JSTSG/(IFWDJ)Problem-0232, I thought the sap.valuesetlimit.maxondemand property would fix this, then realized that this doesn't control the default visibility of how many can be seen at once.

In Studio 7.0 you can can control the Size property of drop-downs by switching between Small & Standard, but after migrating all our Java WD code to NW 7.4, this value has been deprecated and is no longer under our control.

I'm out of ideas. Nothing like these ever happened in NW 7.0 portal servers. Have any of you experienced these or similar issues? Any suggestions for what we can do to fix them?

Please advise,

Jon

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Apr 07, 2017 at 07:22 PM

    did u render wdj in standard mode?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jun Wu

      Hi Jun: sorry for the delay; we had a major outage.

      Unfortunately, setting the SapDocumentMode property didn't change anything. All 3 of the above issues are still with us.

      Thanks,

      Jon

  • Apr 11, 2017 at 12:54 PM

    Hi,

    If you are using browser document mode in edge then all the application use standard

    Refer below note:

    1458799 - Limited supportability for IE8 and above in the Portal

    1814711 - SAP applications iViews in EP: Rendering Modes

    Regards

    Kiruthika

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kiruthika:

      As I tried to explain earlier we cannot use Browser Document Mode property value to IE=5, IE=EmulateIE7, because GUI for HTML trans-iViews that are also part of this same application will render incorrectly, specifically that F4 help and all inbox boxes are frozen and cannot be typed in, edited or changed.

      We have standardized on IE11, but GUI for HTML trans-iViews & Java WD applications requiring Classic Event Framework must live on the same portal server.

      Thanks,

      Jon

  • May 08, 2017 at 10:42 PM

    Hi Jonathan,

    What release is your backend ABAP system? And, in your portal, have you tried using the Ajax Standards Mode Desktop instead of the Classic Standards Mode Desktop?

    Beyond that, a couple other things to check, in your backend, in your WEBGUI and other "SAPGUI for HTML" based ICF services, set the GUI Parameter ~WEBGUI_NEW_DESIGN = 1. Also, have a look at Notes 2007142 and 2140417.

    In your portal, in NWA, check Configuration -> Infrastructure -> Application Modules, filter on module com.sap.portal.appintegrator, drill into component Common_Configuration and property Default value for Browser Document Mode and set the value to edge. You may find that for some iViews the portal will be sending documentMode=IE5 in the URL even though you think you're all in Standards mode if you don't do this.

    Cheers,
    Matt

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Jon,

      Thanks for coming back to this with your eventual solution, although I'm not sure what you mean by "Change (3)," as I only see two bullet points in your solution list. I'm glad you got this resolved!

      With your permission, I'd like to convert your reply to an "answer" so that it can be marked as the correct answer for others in the future. Or, I think you can do this yourself, if you prefer. And then we can close the question.

      Cheers,
      Matt

  • Nov 14, 2017 at 06:19 AM

    Hi,

    Can you check if the note ##2430019 - Incomplete dropdown contents or incorrect position of dropdown in IE11

    helps?

    Regards,

    Asha

    Add comment
    10|10000 characters needed characters exceeded