Skip to Content
avatar image
Former Member

ODBC (RDO) Bug when verifying database

Hello,

I am wondering if there is a known issue with using the ODBC (RDO) data source and trying to update the list of fields in the Field Explorer? I created a simple report that calls a simple stored procedure; the stored procedure is one select statement and displays 4 columns and less than 50 rows. I am unable to update my report when I add a new column to the stored procedure and using an ODBC (RDO) data source for my report. I have tried to use the "Verify Database" and "Set Data Source Location" methods of updating a report but they do not work. They either give me an error message saying, "Data Object cannot be opened/accessed" or "The database table cannot be found. Proceed to remove this table from the report?" or other error messages.

I then tried using an OLE DB (ADO) data source and was able to update my report just fine using either method, "Verify Database" or "Set Data Source Location."

I am using the application Crystal Reports XI, product version 11.0.0.1994

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Apr 06, 2017 at 05:05 PM

    Hi Matt,

    XI is long out of support, you can upgrade to XI R2 SP 4 FP 6 from here:

    http://downloads.businessobjects.com/akdlm/crystalreports/crxir2_sp4_full_bld_0-20008684.exe
    http://downloads.businessobjects.com/akdlm/crystalreports/CRYSTALREPORTS06_0-20008684.EXE

    Use your XP Keycode to install it.

    It could be something in the dB Client blocking it.

    Once converted to OLE DB verify the DB and save the report and now try to convert it back to ODBC.

    Good luck

    Don

    Add comment
    10|10000 characters needed characters exceeded