Skip to Content
Apr 05, 2017 at 02:36 PM

SAPUI5: Die hard cached app


I'm not trying to do anything strange. I made an app and published to the ABAP repository. Then made a change and published it again. But when I run the app in the Fiori Launchpad it always uses the old code. In the past I used a few ABAP programs to clear the cache and that did the trick, but not this time. Maybe in this newer version the cache had evolved to survive.

I can see my app is cached in the server in the route <server>/sap/bc/ui5_ui5/sap/<my app>/~<some hash code>~C/. It always run with this code and I couldn't update it.

This is what I tried so far. Maybe someone can point out something else.


2) I ran programs:







3) I cleared the browser's cache.

4) I manually called the url <URL to SAPUI5 application or component>/do-update-meta-data

5) I added the sap-ui-debug=true parameter to the url

6) I even deleted the app and published it again.

It keeps and keeps and keeps using the same old code.

The Gateway server is a Netweaver 7.51. SAP_GWFND and SAP_UI 751 SP 1. UIX01CA1 200 SP 3.