Skip to Content
V P

Optional and Required App installation Prompt issue

Hello Team,

We have created the Enterprise application with MDM protocol and as Optional.

User downloaded the version 1.x on his device.

We have deployed new version 2.x in the same Enterprise Application (browse and upload and save)

So my question is will the user get the Prompt to Update the App ? once he launch the application?

Once the user open the Afaria Client does he see the update options in below Update option in Afaria Client ?

or Will the application 1.x get auto updated with 2.x without disturbing the end user ?

Here the end user app is getting auto updated with 2.x. is this correct?

Afaria 7 SP16

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    May 24, 2017 at 08:14 PM

    So my question is will the user get the Prompt to Update the App ? once he launch the application?

    I know that for iOS, once the app is installed, the user will never get prompted to update it. It doesn't matter if the app is optional or not, if the app is already installed then the user will never get any prompts about the app. Even if the application policy is required, the upgrade will happen silently without the user getting notified. In iOS 10 any recently updated apps have a blue dot next to their name, but other than that there will be no notification.

    Once the user open the Afaria Client does he see the update options in below Update option in Afaria Client ?

    The user will see an update available in the Afaria client only if the application version number of the updated app is higher than the older version. For example, if the user has app version 1.0 installed, and the Afaria admin uploads version 2.0, then the user will see version 2.0 available as an update in the Afaria client. Keep in mind that the user will only see the red update badge after an updated inventory scan. If Afaria does not know that the app is installed on the device, then it will not let the user know that an update is available.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 06, 2017 at 06:38 AM
    -1

    Hi VP,

    Does following KBA help you?
    https://launchpad.support.sap.com/#/notes/1969247

    Thanks,
    Atsushi

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 10, 2017 at 08:50 AM

    Hi Atsushi,

    No, KBA is different from my question.

    Regards,

    VP

    Add comment
    10|10000 characters needed characters exceeded

  • May 17, 2017 at 06:44 AM

    Hi VP,

    Does following KBA help you?
    2177438 - Update iOS Enterprise Apps installed via MDM and marked as required

    Thanks,
    Atsushi

    Add comment
    10|10000 characters needed characters exceeded