Skip to Content
0
Former Member
Oct 26, 2006 at 11:53 AM

Problem passing data to Oracle StoredProcedures

48 Views

Hello @all,

I run SAP NetWeaver Java EE 5 Edition. My IDE is Eclipse 3.2 and not the Developer Studio because of my Company, I do an Internship and have no influence on that thing.

I have some Problems with an Application ported from Oracle OC4J. The Application runs fine with only few changes to JNDI Names. But I can't find a solution for the following problem:

I created a customDataSource in the NWA with the correct oracle jdbc-driver(ojdbc14.jar) and selected VendorSQL as SQLEngine.

I create a connection to the AS:

con = getDataSource().getConnection();

Then configure my CallParams for the stored Procedure. At the following line

ArrayDescriptor arrayDescriptor = ArrayDescriptor.createDescriptor(

"NUM_TABLE",

con);

I get this error:

java.lang.ClassCastException: com.sap.engine.services.dbpool.cci.ConnectionHandle

at oracle.sql.ArrayDescriptor.createDescriptor(ArrayDescriptor.java:149)

at oracle.sql.ArrayDescriptor.createDescriptor(ArrayDescriptor.java:115)

at de.xavo.bat.radis.dao.callparams.GetCigaretteSpecCallParams.getStatement(GetCigaretteSpecCallParams.java:209)

I started lots of google searches an found results with similar Problems. It must have something to to with the connection. Remote Debugging of the Enterprise Beans shows me, that Netweaver returns a com.sap.engine.services.dbpool.cci.ConnectionHandle. In this Handle is a VendorConnectionHandle in which the connection I need, an oracle.jdbc.driver.T4CConnection is located. The method createDescriptor needs this T4CConnection.

I tried to use the standard DriverManager and called the Database directly without the SAP NetWeaver dbpool andit works fine.

Has anyone an idea how I get the underlying T4CConnection out of the ConnectionHandle and give it to the ArrayDesriptor?

Thanks in advance

Matthias Reizammer

Message was edited by: Matthias Reizammer

Message was edited by: Matthias Reizammer

Message was edited by: Matthias Reizammer