Skip to Content
0

HANA Express Scriptserver not running

Apr 05, 2017 at 08:30 AM

296

avatar image
Former Member

Since some days the scriptserver on my tenant DB doesn't run anymore.

The active status of scriptserver on host hxehost, port 30043 has been NO for 700 seconds.
The active status of scriptserver on host hxehost, port 30046 has been NO for 700 seconds.

I tried already to set the value <1>within daemon.ini[scriptserver] config file on SystemDB:

System --> new value = 1

Host --> new value = 1

But the scriptserver doesn't start.

10 |10000 characters needed characters left characters exceeded
Former Member

Attached some trace files, maybe it's helpful for someone

scriptserver-hxehost-30004-rtedump-20170406-093308.txt

scriptserver-hxehost-30004.txt

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Chris Huston
Apr 06, 2017 at 11:54 PM
1

@Matthias S - can you extend the available memory on this VM hosting HXE? We haven't seen this specific issue with the scriptserver before but have a strong suspicion it is related to limited memory situation.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Are you sure it's because of limited memory? It shows me that there is a lot free memory? And how much would you recommend?

             total       used       free     shared    buffers     cached
Mem:         16080       5526      10554        203          0       1619
-/+ buffers/cache:       3906      12174
Swap:         2053          0       2053
0
Andy Scott
Apr 10, 2017 at 08:54 PM
0

Hi Matthias,

If you are editing the daemon.ini directly, I think you need a restart of hana (HDB stop && HDB start)

If this is not the issue, can you please attach scriptserver trace file?

Thanks

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 07, 2017 at 04:14 PM
0

Hi,

I'm running in the exact same issue.

I have set the value <1> within daemon.ini[scriptserver] config file on SystemDB and stopped / restarted the HDB but the scriptserver is still not running.

Any clues?

Thansk and regards,

Olivier

Share
10 |10000 characters needed characters left characters exceeded