Skip to Content

MCBZ is not generating spool when executed on backgroung

Apr 05, 2017 at 06:03 AM


avatar image

Dear experts,

we have an issue with MCBZ transaction in ECC 6 EHP 6, that it doesn´t generate a spool when report executed on background. When I execute and print on foreground, the spool get´s generated... I tried to search in KBA´s on that, but no luck...

Thanks for any advice.mcbz-backgr.png

mcbz-backgr.png (18.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Jürgen L Apr 07, 2017 at 12:00 PM

you have to make sure that you execute the transaction with a selection version.

see OSS note 60283 - No spool list in background analysis

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Jürgen!

Jürgen L Apr 05, 2017 at 08:35 AM

How did you create the batch job?

Just with F9 instead of F8?

If not, then try it this way and tell if it has a different result.

also check the job log for more information

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Jürgen,

yes, with F9, than I defined a printer and saved with confirmed immediate execution. Job log doesn´t give much info just says:
Job started

Step 001 started (program RMCB1100, variant &0000000000034, user ID MARTVERN)

Job finished


In that case I think SAP has done its duty and the report has left SAP and is already printed or is in the printer queue.

Try it again and click the properties button when defining the print parameters for the background job.

Define the Time of printing under General Properties with "Send to SAP Spooler Only for Now"

And set the Delete immediately after printing to "NO" , and New Spool Request to YES, this is under Output Options.


Hello Jürgen,

thanks for your inputs. The settings you´re mentioning are maintained as default, so they apply all the time...

For you it does work? Could it be an issue fixed by certain service pack?