Skip to Content
author's profile photo Former Member
Former Member

Problem when installing Java add-in for 640 Abap system

The installation terminates at the end on the step that starts the Java engine.

In SMICM I can see following errors:

[Thr 772] *** ERROR => IcmJ2EEScheduleFunc: Cannot access "/sap/public/icman" with protocol "HTTPS" on AppServer - please check

[Thr 2057] Wed Oct 25 15:42:38 2006

We are on AIX 5.3 64bit

Use Java 1.4

During installation I have chose to enable the cryptography. The file I used was downloaded from SAP Market place (tc_sec_java_crypto_signed_fs_lib.sda fro JDF 1.4x). Installation was happy with this file as well as the other one required (for unrestricted access).

Has anyone of you came accross this problem

Regards,

Mariusz

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Oct 26, 2006 at 06:27 AM

    Hi Maruisz,

    Have you setup the profile to handle HTTPS? if not

    you need to add a few parameter to the instance profile.

    See

    http://help.sap.com/saphelp_nw04s/helpdata/en/56/2e453cabf4ef6fe10000000a114084/frameset.htm

    Hope this help

    Juan

    Please reward with points if helpful

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 26, 2006 at 11:38 AM

    Please find updated description of my problem.

    I have checked those parameters and they were not there. But I also checked our other systems (2004s 700) for which abap and java are installed in one run of sapinst. They work fine and they don't have those parameters set.

    Regards,

    mariusz Draber

    We have installed a WAB AS ABAP 640 system and now we are trying to

    install Java ADD-in.

    The installation fails at the Start J2EE engine step.

    Originally in SMICM I have seen following errors:

    [Thr 772] *** ERROR => IcmJ2EEScheduleFunc: Cannot

    access "/sap/public/icman" with protocol "HTTPS" on AppServer - please

    check

    [Thr 2057] Wed Oct 25 15:42:38 2006

    We are on AIX 5.3 64bit

    Use Java 1.4

    During installation I have chose to enable the cryptography. The file I

    used was downloaded from SAP Market place

    (tc_sec_java_crypto_signed_fs_lib.sda fro JDF 1.4x). Installation was

    happy with this file as well as the other one required (for

    unrestricted access).

    I tried number of things:

    - restarted SAP (ABAP). After that the errors:

    Cannot access "/sap/public/icman" with protocol "HTTPS"

    no longer appear. Now when sapinst is running it fails on the same step

    but this time in SMICM I see:

    ICM Trace File (dev_icm)

    trc file: "dev_icm", trc level: 1, release: "640"

    systemid 324 (IBM RS/6000 with AIX)

    relno 6400

    patchlevel 0

    patchno 43

    intno 20020600

    make: multithreaded, Unicode, 64 bit

    pid 1925204

    [Thr 1] Thu Oct 26 10:48:01 2006

    [Thr 1] ICM running on: ddrsap18

    [Thr 1] MtxInit: -2 0 0

    [Thr 1] IcmInit: listening to admin port: 65000

    [Thr 1] DpSysAdmExtCreate: ABAP is active

    [Thr 1] DpSysAdmExtCreate: JAVA is not active

    [Thr 1] Thu Oct 26 10:48:06 2006

    [Thr 1] DpShMCreate: sizeof(wp_adm)##13200#(1320)

    [Thr 1] DpShMCreate: sizeof(tm_adm)##3434688#(17088)

    [Thr 1] DpShMCreate: sizeof(wp_ca_adm)##24000#(80)

    [Thr 1] DpShMCreate: sizeof(appc_ca_adm)#8000#(80)

    [Thr 1] DpShMCreate: sizeof(comm_adm)##316000#(632)

    [Thr 1] DpShMCreate: sizeof(vmc_adm)##0#(456)

    [Thr 1] DpShMCreate: sizeof(wall_adm)##(40056/36728/64/192)

    [Thr 1] DpShMCreate: SHM_DP_ADM_KEY##(addr: 0x700000020000000, size:

    3879936)

    [Thr 1] DpShMCreate: allocated sys_adm at 0x700000020000000

    [Thr 1] DpShMCreate: allocated wp_adm at 0x700000020001bb0

    [Thr 1] DpShMCreate: allocated wp_adm at 0x700000020001bb0

    [Thr 1] DpShMCreate: allocated tm_adm_list at 0x700000020004f40

    [Thr 1] DpShMCreate: allocated tm_adm at 0x700000020004f68

    [Thr 1] DpShMCreate: allocated wp_ca_adm at 0x70000002034b828

    [Thr 1] DpShMCreate: allocated appc_ca_adm at 0x7000000203515e8

    [Thr 1] DpShMCreate: allocated comm_adm_list at 0x700000020353528

    [Thr 1] DpShMCreate: allocated comm_adm at 0x700000020353540

    [Thr 1] DpShMCreate: allocated vmc_adm_list at 0x7000000203a07a0

    [Thr 1] DpShMCreate: system runs without vmc_adm

    [Thr 1] DpShMCreate: allocated ca_info at 0x7000000203a07c8

    [Thr 1] IcmCreateWorkerThreads: created worker thread 0

    [Thr 1] IcmCreateWorkerThreads: created worker thread 1

    [Thr 1] IcmCreateWorkerThreads: created worker thread 2

    [Thr 1] IcmCreateWorkerThreads: created worker thread 3

    [Thr 1] IcmCreateWorkerThreads: created worker thread 4

    [Thr 1] IcmCreateWorkerThreads: created worker thread 5

    [Thr 1] IcmCreateWorkerThreads: created worker thread 6

    [Thr 1] IcmCreateWorkerThreads: created worker thread 7

    [Thr 1] IcmCreateWorkerThreads: created worker thread 8

    [Thr 1] IcmCreateWorkerThreads: created worker thread 9

    [Thr 2828] IcmWatchDogThread: watchdog started

    [Thr 3342] ISC: created 400 MB disk cache.

    [Thr 3342] ISC: created 50 MB memory cache.

    [Thr 3342] HttpSubHandlerAdd: Added handler HttpCacheHandler(slot=0,

    flags=12293) for /:0

    [Thr 3342] HttpSubHandlerAdd: Added handler HttpSAPR3Handler(slot=1,

    flags=4101) for /:0

    [Thr 3342] HttpSubHandlerAdd: Added handler HttpJ2EEHandler(slot=2,

    flags=1077253) for /:0

    [Thr 3342] Started service 8006 for protocol HTTP on host "ddrsap18"(on

    all adapters) (timeout=30

    [Thr 258] MPI<3>0#3 Peak buffer usage: 1 (@ 64 KB)

    [Thr 3342] IcmNetCheck: network check passed without detecting problems

    [Thr 772] MPI<5>2#3 Peak buffer usage: 2 (@ 64 KB)

    [Thr 1029] MPI<7>4#3 Peak buffer usage: 3 (@ 64 KB)

    [Thr 1286] MPI<9>6#3 Peak buffer usage: 4 (@ 64 KB)

    [Thr 1543] Thu Oct 26 10:48:07 2006

    [Thr 1543] MPI<b>8#3 Peak buffer usage: 6 (@ 64 KB)

    - I created the client copy 000->001 a rerun the java installation

    reffering to 100 rather then 000 (DDIC user). Also did not help

    - I generated the certificate in STRUST (it was not there while other

    installs on ECC 6.0 had it after installation)

    The think that makes me wonder is that on the server in question I

    cannot see directory

    /usr/sap/DBS/D*/j2ee/cluster/server0

    while on other installed systems I can.

    Before installing an ADD-IN java do I have to install standalone java?

    Why didn't installation create those directories?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.