Skip to Content
avatar image
Former Member

Error while obtaining JCo connection

Hi,

when I want to create a JCO Connection I get this error :

Failed to create new JCO client connection WD_FLIGHTLIST_METADATA_DEST:

com.sap.tc.webdynpro.services.sal.sl.api.WDSystemLandscapeException: Error while obtaining JCO connection.

I have found some topic about this problem, but no solution for me.

In the "Adaptive RFC - Troubleshooting Guide", the 2 solutions are :

1. Please run Adaptive RFC within the J2EE engine environment only : how can I do this ?

2. The problem could be that the SLD does not contain logon groups for the R/3 system you refer to via

message server connection : in my creation wizard the logon groups and system name are empty ! Is it normal ?

However in the "Content Management" from Web Dynpro the "SLD connection test" works fine.

I already imported the CR_Content.zip and the cimsap.zip, and executed all installation templates from NW !

What configuration is missing ?

Thank you for your help.

Regards,

Mathieu

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 21, 2006 at 01:33 AM

    HI

    Go through this link .

    how-to-go-for-a-jco-connection

    it might helps.

    Thanks

    Lohi.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi lohi,

      I have already read this guide, my questions are :

      In your link "Adaptive RFC - Troubleshooting Guide", the 2 solutions are :

      1. Please run Adaptive RFC within the J2EE engine environment only : how can I do this ?

      2. The problem could be that the SLD does not contain logon groups for the R/3 system you refer to via

      message server connection : in my creation wizard the logon groups and system name are empty ! Is it normal ?

      Have you got an idea ?

      Thanks,

      Mathieu