Skip to Content
author's profile photo Former Member
Former Member

Strange error in retail store (u0093browser errors after migrationu0094)

Dear Sirs,

After converting the retail store solution from standalone to internal ITS (wsta, wosm), we are experiences some rather strange problems.

The solution has been in testing for a number of days and everything works well for a large portion of the users, however out of 500 test orders (logins where we create orders) 3 of them do not get the to see the order list. They only get a blank page.

The strange thing is that after deleting the cache and cookies, it works. Another issue which seems to arise is that the status bar in IE is blinking, and by doing a refresh F5 things are working. The errors are probably connected.

And as far as I can see the error does not come back to the users who have deleted the cache&cookies. The users is assigned an order list based on a plant parameter which is set in SU01, so there should not be any cookies which determines the order list.

I find this error very strange, and would appreciate any ideas on how to locate the problem, or any considerations from you. Do you think this error is on the internal ITS or the browser side.

Has anyone else noticed browser error following a migration from standalone ITS to internal ITS?

I am aware there is a note on migrating wsta on internal ITS, but this does not seem to give me any input relevant to this specific problem.

I will be truly grateful for any hints or tips, as I need to see this problem with a new perspective.

Best regards,

Jørgen

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Oct 23, 2006 at 11:27 AM

    Hi Jørgen,

    with the integration of ITS in the SAP kernel, a feature called content expiration is supported. The Web server (ICM) sets a field in the HTTP header which tells the web browser not to load the file again from the server until the time period specified in the HTTP header field is expired. For integrated ITS this HTTP header field is set by default 8 hours for all files stored below /sap/public/bc/its/mimes/ where the mime files used by ITS services are located.

    If you do an upgrade like applying a services pack it is possible that due to this time period the browser uses mime objects from the cache instead of requesting them from the server. I.E. outdated JS files which are not in sync with the generated HTML can lead to JS errors. This would explain why your users don't experience the issue after clearing the cache.

    Best regards,

    Klaus

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello again everyone,

      could the fact that I have not explicitit defined a usertime and a timeout value in the SICF have anything with this error?

      just need to get that checked out as a possible candidate :=)...

      regards,

      Jørgen

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.