Skip to Content
author's profile photo Former Member
Former Member

Server Component?

Hello,

I am assembling an web application with the deploy tool. The webapp is not developed by SAP Netweaver Studio. The webapp is using some libraries, which i want to add to the server classpath for re-use. I have created a 'Server Component' and deployed it in the server. But when i start the web application, after deployment, i get an ClassNotFound exception. Did i forget or missed something? Did i had to restart the server? Or did i had to link the application with the 'Server Component' jars?

Im using 2004s, SP9.

Regards,

Endy

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2006 at 08:39 AM

    You need to specify references to used libraries in the provider.xml of your web application.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2006 at 08:56 AM

    Pascal,

    Thanks for your reply. There is no provider.xml in my Web application. The provider.xml is a SAP definition file. I am not developing in Netweaver Studio. Can I generate a provider.xml using the Deploy Tool?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.