Skip to Content
0

Twitter Integration with SAP CRM not working

Apr 04, 2017 at 08:12 AM

144

avatar image

We are implementing a SAP CRM 7.0 EhP3 integration with Twitter. We are trying to hit the twitter endpoint https://api.twitter.com/1.1/statuses/mentions_timeline.json but we are getting CONNECTION REFUSED 404 error (NIECONN_REFUSED(-10)) The same error is for other twitter API endpoints we are trying to hit. The valid certificate is implemented (Verisign Class 3 Primary CA - G5 certificate) as recommended by SAP notes 1832480, 1832462, 1859791 relevant for this scenario.

In the log or when we test the GET_POST method, the error we see isConnect to api.twitter.com:443 failed: NIECONN_REFUSED(-10).

The screenshot below shows the installed SSL Certificate.

Screenshot of HTTP trace

Additional Info:

The server has no proxy.

The Twitter tokens are not expired, they are fine.

Up to now, we do not know the cause of the errors indicated above. We are not sure if the server is being blocked by twitter due to the frequency of requests, or if there is another cause of the error.

Anyone has an idea what might be the problem?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Gilbert Twesigomwe Apr 14, 2017 at 03:15 PM
0

We got it working after the server was demilitarised (given full access to the internet), and the proper root SSL certificate was added.

Note: After the server was demilitarised, we got a new error which was "SSSLERR_PEER_CERT_UNTRUSTED". Using the guidance of this tutorial, we added a proper root certificate and we got the problem solved.

Share
10 |10000 characters needed characters left characters exceeded
Sigrid Wieshofer
Apr 06, 2017 at 06:53 AM
0

Hello,

I have to admit that I am no expert in setting up this scenario but some hints - just in case you haven't checked that:

With regard to error "Connect to api.twitter.com:443 failed: NIECONN_REFUSED(-10). "
Did you check if port 443 is open for communication, e.g. in your firewall. You should be abel to telnet the port if the connection is ok.

Did you check an ICM trace with level try as outlined in https://wiki.scn.sap.com/wiki/x/c4E_FQ?

Request_in_failed error might be caused by inactive HTTPS protocal in SMICM for outgoing communication.



Best Regards,
Sigrid

Share
10 |10000 characters needed characters left characters exceeded