Skip to Content
author's profile photo Former Member
Former Member

Repair FULL to ODS - Cube Data Inconsistent

we have loaded Data into a Historical cube that maintains a " monthwise version " of all data loaded into an Z-R/3 table .The flow is from R/3 table -> ODS - > CUBE . First we did

Initialization and then delta's were running fine for next few months .

one fine day in NOVEMBER, we realised that the data in R/3 and BW was not matching cause

user's were changing the R/3 table from the table maintenance generator and no DATE/TIME

field was getting affected ,so no DELTA was being triggered .

Now we had to correct this NOVEMBER DATA with out affecting the for data older "month versions " which is perfectly alright. This delta data was not available in PSA or RSA7 .

P.S : The " month version " is created at the first load ( i.e on the first of every month ).

If we extract from our infopackage by using selection criteria (by using "november month

version " the complete delta process / earlier monthly versions would be gone( again we need to do reinitialize).

So we changed the load from r/3 to ODS from DAILY DELTA to DAILY FULL REPAIR REQUEST( also

cause NO DELTA MECHANISM WAS GETTING TRIGGERED INCASE OF CHANGES IN TABLE MAINTENNACE) ..i

guess the developer here did a selective deletion from ODS & CUBE before running a "FULL REPAIR REQUEST " .However , the i believe that the activation queue and the ChangeLog remain unchanged during the selective deletion of the data from the ODS , so although the DATA in ODS is CORRECT and has been Updated into the CUBE ..but CUBE DATA IS STILL INCORRECT

...

Can any of you experts please please help me resolve this issue .

thanks all

anya

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2006 at 05:31 AM

    Hi,

    <i>i believe that the activation queue and the ChangeLog remain unchanged during the selective deletion of the data from the ODS , so although the DATA in ODS is CORRECT and has been Updated into the CUBE ..but CUBE DATA IS STILL INCORRECT</i>

    When you do activation after selective upload, the entries will be created in Change log table. So those entries are used as delta . When you are doing Repair request system sends the records as New records.So these records will reach to Change log and Cube as New records only.

    So every thing works perfectly,no need to changed the load from r/3 to ODS from DAILY DELTA to DAILY FULL REPAIR REQUEST.

    With rgds,

    Anil Kumar Sharma .P

    Message was edited by: Anil Kumar Sharma

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 19, 2006 at 05:42 AM

    Hi Anya..

    If the Loads are INITS or Deltas:

    !)First the data will be in Activation Q

    2)The data gets into changelog (up on activation)

    3)The data in Activation Q is delted (after activation)

    4) The cube takes the data from the Change log tables

    IF the Load is a Full loads....

    The data update to cube is done from the Active table...

    Please correct me if im wrong

    regrds

    AK

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.