Skip to Content
avatar image
Former Member

SOAP Request not reaching to 3rd party system

Hi , I have a secenario where SOAP request sending to 3rd party system. It's synchronous secenario ( SOAP - SOAP ). In PI Audit log says messages are delivered status with error 'error in response'. in this particular context in SAP PI and 3rd party systems, what are the pre requites to check before sending a message? I have used basic authentication at receiver communication channel. Could you please explain technical possibilities required for sending and receiving system?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Apr 03, 2017 at 11:25 PM

    Hi Praveen,

    Did you try to trigger the webservice via external tools like Soapui? it is always good to access the webservice from soapui to test the connectivity and type of authentication.

    regards,

    Harish

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 04, 2017 at 06:18 AM

    I second Harish's suggestion. By far the fastest way to tackle any initial misconfigurations in a SOAP scenario.

    In addition you could increase logging, depending of course on your PI version and if you are on double stack or single java stack (AEX).

    On AEX you would go to the iFlow or ICO (depending on whichever you use) and increase logging there to always log. Then you would also get access to the response message with a hopefully meaningful error from the receiver system.

    HTH

    Cheers Jens

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 04, 2017 at 06:56 PM

    Hi Praveen,

    Any messages with delivered status with error 'error in response' is due to the late response from 3rd Party system. The message from PI is successfully sent to 3rd party system but no response is received. Please check with 3rd Party system team if message was received

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Shamala!

      As far as I remember "error in response" status can be received when HTTP response code is not "HTTP 200 OK". Also it was said above that call from SOAP UI is performed without any error.

      Regards, Evgeniy.