Skip to Content
author's profile photo Former Member
Former Member

Length of the screen field

Hi,

I am doing module pool programming, I have defined a field as pxxxx-currency(length 13) as an I/O . But on the screen painter I reduced the field length to 8 characters and so when I execute its taking 8 characters only as input but I want the field to take 13 characters I mean as we type it should take take in the whole 13 and I really do not care if it hides the first or the last characters and I cannot increase the field lenght because of the size restricitons as I have already maxed out with the screen width. All suggetions are appreciated and suitable rewarded.

Regards

Vick

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2006 at 03:27 PM

    Hi Vick,

    There is a scrollable indicator just above the length defintions. If you select that then you can set the Visible and default lengths.

    Hope this helps.

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

    • Ok, here is what I did to get it to work, set the field to a type CHAR field.

      Make the Def Length what ever you want, set the scrollable checkbox to checked( hit enter ), change the visiable length to whatever you what. Now change the field data type back to CURR. It will hold the values that you entered when it as a CHAR data type field.

      Regards,

      Rich Heilman

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2006 at 03:15 PM

    vick ,

    do one thing , go to screen layout ,, in that change the same in field properties or ,,

    delete that column and add one more time ,save and activate ...

    here is the default length is 8??

    vijay.

    Add a comment
    10|10000 characters needed characters exceeded

    • I don't think that you can control this with a CURR type field. It is not allowing me to make the visible length different than the definition length, nor am I allow to make the field scrollable. This maybe only allowed for character type fields.

      Ok, it does appear that you can change the vis length differnet form the def length for fields that are of type CURR, DEC, QUAN, there could be others.

      Regards,

      Rich Heilman

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2006 at 03:25 PM

    Hi ,

    In your screen painter( Field attributes ) you have a checkbox called 'Scrollable' . Check that.

    Then set your Def.lenght as 13 and Visible length as required.

    Hope this solve.

    Regards,

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Scrollable is greyed out for me.

      Rich - I will try out your procudure .

      regards

      Vick

      Rich - It solved my problem, you have read my mind as usual.

      Thanks guys for all the inputs

      Message was edited by: vick vennav

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2006 at 03:34 PM

    do this ,

    goto layout editor ,,

    select the column and say ctrl elements push button ,

    this will give u a pop up screen

    in that select the column field and click the attributes option

    this will lead u to a screen ..it is element attributes display screen , remember u r doing this in change mode ,,

    in here in the right top portion

    Def.Lgth 13 VisLgth 8

    maintain these values ..

    regards,

    Vijay.

    ive shown u the navigation in version 4.6c ,,

    hope this helps

    u can use numc also for the data type

    right rich ,,

    Message was edited by: Vijay

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2006 at 03:09 PM

    hi vick,

    u can set the visible length to 8 chars and default will be 13 chars in the field attributes display option ..

    did u check that..

    check this option in the field attributes default length will be 13 and set visible length to 8,

    regards,

    Vijay.

    Message was edited by: Vijay

    Message was edited by: Vijay

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.