Skip to Content
0

SAP Cloud Platform SDK for iOS - Project Generation Error

Apr 03, 2017 at 11:42 AM

238

avatar image
Former Member

Hello all,

I was trying to start to play around the new SAP Cloud Platform SDK for iOS, but run in to a problem in the Xcode project generation step.

Context Information:

  • macOS Sierra 10.12.4
  • Xcode 8.3
  • SDK downloaded from SAP store for 8.3 version
  • SAP Cloud Platform Trial Account in use

Problem - I Installed the SDK as per the videos from Andreas in https://www.sap.com/developer/topics/cloud-platform-sdk-for-ios.html

Connections setup all OK, but when getting to the final step of generation the Xcode project, the system throws the following message:

I recreated my steps leading to this point, and nothing appears to be different from the steps provided in the video.

I'm unable to find that Console utility the message refers...maybe that could help to cast some light in the causes of this message...

The remaining objects that are described in the wizard are created in the SAP Cloud Platform as they should and were create using the SAPcpms sample option to minimize user error. In the following image there are more than one because I tried to troubleshoot by creating new objects:

so I believe is not a authentication problem.

Can anyone please help?

Thanks in advance,

Pedro

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Apr 03, 2017 at 06:19 PM
0

Hi Robin,

Thank you for the reply and help.

Unfortunately it doesn't say much to me personally ...it seems something with the frameworks, but I installed the one for Xcode 8.3 and the file structure is untouched, residing in the Applications Folder:

The log for the generation part is as follows:

The last message in detail:

And prior to that generation step, it logged the following errors:

Really at a lost here...

Thank you,

Pedro


Show 5 Share
10 |10000 characters needed characters left characters exceeded

It looks like it failed prior to that; at the five lines starting with "Message"

1

Hi Pedro,

Could you please show us the full log of the lines, which are starting with "Message Process to execute" and "Message Content to generate"?

Thanks,

David

0

Hi Pedro,

Can you please also show the line "Xcode proj file:///..."

Thanks,

Adam

0
Former Member

Hi all,

Sorry for the late reply. Here are the screen shots you requested:

Thanks for all the help.

Pedro

0

Hi Pedro,

As far as I can tell from the logs, there seems to be a invalid character in the path. It is in the first screenshot you have attached under a red part, look at '/SAP/Projectos/........./iOS SDK/demoProject...'.

I assume that the text under the red highlight is sensitive data and by no means, would I want to see the whole text, but knowing which exact character could cause the issue would help us a lot.

Can you please tell us at which character does the '^' points at?

Thanks,

Adam

2
Robin van het Hof
Apr 03, 2017 at 04:40 PM
1

Hi Pedro,

The Console utility is the standard macOS "Console" application (located in your Applications folder).

Open the Console app, filter by "SAP Cloud Platform SDK", run the SDK Assistant again, and see what messages or errors are logged in the Console.


Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Robin,

I opened the console and run assistant after that, but still no result displayed on console.

Do you know why?

Thank you

0
avatar image
Former Member Apr 10, 2017 at 09:02 PM
0

Hello all,

Thanks to Adam's comment I was able to figure out the problem and I'll put it here for reference:

In the first screen of the project creation wizard, I was giving a path that contained a ''Á" character that by some reason cannot be handled by the program and therefore prevents the project to be created.

Thanks a million for all you help.

Pedro

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Robin & Adam, I tried to give you points, but can't find them, but to all that commented on my question and specially you both, many thanks.

Pedro

0