Skip to Content
author's profile photo Former Member
Former Member

Duplicae records in Master data

Hi all

We have an infosource 0FI_AR_3 that loads to an infoobject 0BILL_NUM and to an ODS 0FI_AR_O03. Yesterday, the load to the ODS was fine but the load to the InfoObject 0BILL_NUM has failed giving me the following error;

"128 duplicate record found. 4115 recordings used in table /BI0/XBILL_NUM"

"128 duplicate record found. 4115 recordings used in table /BI0/PBILL_NUM"

Is there a way I could fix this error. Could some one help me please.

Regards,

S.P

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 16, 2006 at 02:43 PM

    Hi,

    In the info package you can set the uploading option to PSA and Ignore duplicate data.

    Cheers,

    Kedar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 16, 2006 at 02:45 PM

    Choose the options in the infopackage

    -- only psa

    -- subsequent in the the datatargets

    -- ignore double data records

    Hope it helps.

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 16, 2006 at 02:45 PM

    Hi,

    did ou try with setting 'Ignore double records' in InfoPackage under Processing tab?

    regards

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 16, 2006 at 02:47 PM

    Hi SP,

    Since you are using a transactional datasource to load to master data, you will not have the Ignore Duplicate records option. You can try to prevent such errors in the future by setting error handling in the InfoPackage Update tab.

    Hope this helps...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 16, 2006 at 02:52 PM

    Hi Everybody,

    Thank you for responding. I already have the setting in my InfoPackage as "PSA Only, Update subsequently into Data targets".

    Since I have this infopackage loading to both Master Data and an ODS, I will not have the option of selecting "Ignore Double Data records" in the infopackage.

    So this boils down to the problem I have in the data load today.

    What other option do I have to fix this issue.

    ~S.P

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Well there are the 2 options suggested by Bhanu and me, i.e to set up the error handling on the BW side and investigate on the source side how the data is set up and why the duplicate data is appering. You need to understand and eliminate the root cause for the duplicate data and the best bet to start off is on the source side.

      The other option you can use is to write a start routine to filter out the duplicates.

      But I would recommend that this be fixed on the source side if the problem lies there.

      Cheers,

      Kedar

  • Posted on Oct 16, 2006 at 05:37 PM

    Hi SP:

    THis is just an idea. What if you try to load MD from ODS. THis way, depending on your ODS keys, the ODS already aggregates and then your MD load should be OK.

    Ofcourse, it all depends on ODS Key Fields.

    Good luck

    Ram C.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.