$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

Custom SAPUI5 app. on launchpad fullscreen

Apr 01, 2017 at 09:34 PM

371

avatar image
Former Member

If one has created a custom SAPUI5 application that points / uses src="https://sapui5.hana.ondemand.com/1.38.8/resources/sap-ui-core.js"

but has an older embedded Gateway server on their sandbox. Would that prevent them from using fullscreen: true in their Component.js? I've got the launchpad "Additional Information" at SAPUI5.Component and my application works with the lauchoad but I can't get it to be fullscreen? Any ideas?

I've read that the FES must match the BES?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Jun Wu Apr 03, 2017 at 02:59 AM
0

launch pad only needs the component js to start your app. html has no place in this case.

Share
10 |10000 characters needed characters left characters exceeded
Jun Wu Apr 02, 2017 at 01:36 AM
0

you have no chance to specify the ui5 version if you run your app through launchpad.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

OK, so I changed my app. to reflect my own resources; it's now

<script id="sap-ui-bootstrap" src="./resources/sap-ui-core.js"

I have sap.ui.core.UIComponent.extend("ZCW_SNAP_BILLNG.Component" in my Component.js I also have a blank Component-preload.js and in my lpd_cust for my application "Additional Information" I have SAPUI5.Component=ZCW_SNAP_BILLNG and I still cannot get full screen. If I go to SAP.Component=ZCW_SNAP_BILLNG my app. loads but not in full screen. Any other ideas?

we're at 1.18.1xx

Thanks!

0
avatar image
Former Member Apr 02, 2017 at 04:36 PM
0

OK, so I changed my app. to reflect my own resources; it's now

<script id="sap-ui-bootstrap" src="./resources/sap-ui-core.js"

I have sap.ui.core.UIComponent.extend("ZCW_SNAP_BILLNG.Component" in my Component.js I also have a blank Component-preload.js and in my lpd_cust for my application "Additional Information" I have SAPUI5.Component=ZCW_SNAP_BILLNG and I still cannot get full screen. If I go to SAP.Component=ZCW_SNAP_BILLNG my app. loads but not in full screen. Any other ideas?

Thanks!

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 02, 2017 at 04:45 PM
0

I forgot to mention we're at 1.18.1xx

Share
10 |10000 characters needed characters left characters exceeded
Krishna Kishor Kammaje
Apr 02, 2017 at 04:46 PM
0

Where are you providing this <script> tag. For a Fiori application, you do not provide an index file, so there is no place to mention a script tag.

Are you running you application standalone?

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Here's my component.js file and my index file. That calls my Component.js This was a standalone app. that I now want in the Launchpad.

So you're saying forget the index file and just use the Component.js? If I rename my index.html to .2index.html it still does the same.

Here's my Component.js

jQuery.sap.declare("ZCW_SNAP_BILLNG.Component");
sap.ui.core.UIComponent.extend("ZCW_SNAP_BILLNG.Component", {

metadata : {
config : {
fullWidth : true
}
},

createContent: function(){

var oI18nModel, ui5core;
ui5core = sap.ui.getCore();
var slang = "fr";
slang = "en";
oI18nModel = new sap.ui.model.resource.ResourceModel({bundleUrl:"i18n/messages.properties", bundleLocale:slang});
sap.ui.getCore().setModel(oI18nModel, "i18n");
ui5core.setModel(oI18nModel, "i18n");
var oResourceBundle = oI18nModel.getResourceBundle();

var oView = sap.ui.view({id:"idMain1", viewName:"ZCW_SNAP_BILLNG.snap.modules.Bill", type:sap.ui.core.mvc.ViewType.JS});

oView.setModel(oI18nModel, "i18n");
return oView;
}

});

Here's my index.html file.

<!DOCTYPE HTML>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta http-equiv='Content-Type' content='text/html;charset=UTF-8'/>
<title>Curtiss Wright SNAP Application</title>

<script id="sap-ui-bootstrap" src="./resources/sap-ui-core.js"
data-sap-ui-theme="sap_bluecrystal"
data-sap-ui-libs="sap.ui.commons, sap.ui.table, sap.m"
data-sap-ui-xx-bindingSyntax="complex"
data-sap-ui-resourceroots='{ "ZCW_SNAP_BILLNG": "./" }' >
</script>

<style type="text/css">
.Total {
background-color: LightGrey !important;
}
.green {
background-color: LightGreen !important;
}
.red {
background-color: OrangeRed !important;
}
.yellow {
background-color: Khaki !important;
}
</style>

<style type="text/css">
.hdr1 {
padding: 1;
height: 2rem;
background-color: Khaki !important;
}
.hdr {
padding: 0;
height: 0rem;
}
.hdr3 {
padding: 1;
height: 2rem;
background-color: LightSlateGray !important;
}
.hdr4
{
border-right: 1px solid black;
}
</style>

<script>
sap.ui.localResources("snap");
</script>

<script>
(function(){
//"use strict";
//register modules paths
jQuery.sap.registerModulePath("util", "./snap/js/lib/util/"); //our own libs
jQuery.sap.registerModulePath("modules", "./snap/modules/"); //controllers and views
jQuery.sap.require("util.app");
})();
</script>

<script>
sap.ui.getCore().attachInit(function() {
new sap.m.Shell({
app: new sap.ui.core.ComponentContainer({
height : "100%",
name : "ZCW_SNAP_BILLNG"
})
}).placeAt("content");
});
</script>

</head>
<body class="sapUiBody" id="content">
</body>
</html>

0

Right. So forget index file and concentrate on Component file. As I see you have used the right parameter.

Now what I am doubting is that you might be using a shell as your container, and you might have manually set the width to less than 100%. Check your view code.

0
Former Member

Thanks Krishna, I got it to work once I stripped it down to just the Component.js, view and the controller.

0