Skip to Content
0

S/4HANA on-premise - Custom fields and logic - Not possible to add a field

Apr 01, 2017 at 03:37 PM

248

avatar image

keyuserextensibility.pngHi all,

I have done all steps of the implementation guide:

https://uacp2.hana.ondemand.com/viewer/825e9222e7ad4fe1988c6cc600bda779/7.51.1/en-US/17749ad749e24701b990e4f38a16eaa8.html

But still can not add a custom field from Custom fields and Logic app.

The add button is deactivated.

Any tip please?

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Jocelyn Dart
Apr 06, 2017 at 09:31 AM
0

Hi Mohamed

Have you completed the prerequisite configuration for the Adaptation Transport Organizer as well?

And of course check you have assigned the authorization roles mentioned?

You should see a list of example custom fields if everything is turned on correctly.

Rgds

Jocelyn

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Hi Jocelyn,

Thank you very much for your reply!

Just today the Basis guys solved it! It was related with some timeout setup in our webdispatcher! Incredible :-)

All the steps were done correctly.

Then I'm facing another problem now, always related with this app.

When you want to add a field, the Business context description were repeated.

Then I looked for an SAP note (2452025) , which theoretically was supposed to fix it.

BUT! It does some some modifications on class CL_APS_CUSTOM_FIELD_DPC_EXT and apparently does not declare method "GET_BUS_CONTEXT_DESCRIPTION" . It is a recent note! It looks like I'm the first one to face this problem!

screenshot2.png

Now the app does not work! :(

screenshot3.png

Any input?

Thank you!!

screenshot2.png (23.7 kB)
screenshot3.png (211.6 kB)
0

Hi Mohamed,

As per of our community rules of engagement ONE problem per thread please! Otherwise everyone gets very confused.

Please post a NEW question

Thanks

Jocelyn

0