Skip to Content
0

CLOB Field Not working_Multisource Universe with Oracle 11 4.2 sp3

Apr 01, 2017 at 07:06 AM

149

avatar image

Hello dear members,

We are facing issues with CLOB type of field with multi-source universe. The below are environment details.

Environment details

Operating system

Windows 2008 Server R2 Standard

Current Business objects Version

Business Objects 4.2 SP3

CMS and Reporting Database and version

CMS database: SQL Server 2012 SP3 Reporting DB: Oracle 11g

Type of Connections used

Multisource universe using Oracle connections. Oracle OCI driver for Oracle 11

Field with data Type as “CLOB” does not work in Webi report/IDT.

Scenarios tested with different data type settings:

Scenario 1: Data Type of the subject field was changed from “VARCHAR” to “LONGVARCHAR” at the data foundation layer. Object Type Changed to “Long Text” at the Business Layer Result: 1 Object parses successfully.

2.Show Object Values returns an error “ORA-00932: Inconsistent datatypes: Expected – got CLOB”

Scenario 2: A calculated column was created at the data foundation layer with the formula stated below and data type set to “VARCHAR”. Object Type set to “String” at the Business Layer Formula of Calculated Column: dbms_lob.substr("RPTB_DWH_FACILITY"."INTERNAL_REMARKS",dbms_lob.getlength("RPTB_DWH_FACILITY"."INTERNAL_REMARKS"), 1 ) Result:

1. Object parses successfully.

2. Show Object Values returns data successfully.

3. Query created at business layer level for testing returns data successfully.

4. Query created in a new Web Intelligence Report returns an error “Database Error: (CS) “Unexpected behaviour: com.sap.connectivity.cs.core.CS Error: Bad Value for field”. (IES 10901)(Error: INF))”

I have seen a KBA for this issue that was 2154041, but i didn't see any update.

Anyone who has encountered this scenario, Please let me know.

Thanks,

Mehraj

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers