Skip to Content
0

"404 - Not Found" when sharing Application URL

Mar 31, 2017 at 11:48 PM

580

avatar image
Former Member

Hello,

I hope you are well.

I have deployed a Fiori app to the Hana Cloud Platform and it works fine on my side. But the app does not load when sharing the "Application URL" with colleagues or when opening the link using chrome's "incognito" window or internet explorer's "inPrivate browsing".

How can I make my application available and accessible to my colleagues and outside users?

Please see screenshots attached and below:

Do I have to change any settings to make my app available externally?

Launching the application link in a private browser results in 404 errors and the application does not load.

capture.png (88.5 kB)
capture2.png (219.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Jamie Cawley
Apr 03, 2017 at 06:35 PM
0

If the users do not exist on the cp account then you would have to set the authentication method to none. See

https://help.hana.ondemand.com/help/aed1ffa3f3e741b3a4573c9e475aa2a4.html

Regards,

Jamie

SAP - Technology RIG

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Jamie,

Thank you for the reply.

I believe I have correctly set authentication method to "none" in the neo-app.json file. But when opening the application link in a incognito or private browser I receive several 404 - not found errors.

Please see the first errors below along with screenshots:

1. GET https://allsolutionsretry-i831410sapdev.dispatcher.int.sap.hana.ondemand.com/resources/sap/collaboration/themes/sap_belize/library-parameters.json 404 (Not Found)

2. Could not load theme parameters from: https://allsolutionsretry-i831410sapdev.dispatcher.int.sap.hana.ondemand.com/resources/sap/collaboration/themes/sap_belize/library-parameters.json - Not Found

3. Uncaught Error: failed to load 'solutions/Component.js' from ../webapp/Component.js: 404 - Not Found

reply1.png (53.5 kB)
reply2.png (148.8 kB)
0
Jamie Cawley
Apr 07, 2017 at 01:18 PM
0

It looks like your resourceroots in your index page is wrong. It should be

data-sap-ui-resourceroots='{"solutions": ""}'

Regards,

Jamie

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Jamie,

Thank you for your patience and assistance, it is greatly appreciated.

I believe I have changed my index.html page as you have instructed. But the issue still remains. The application loads fine on my computer, but the link/application does not load (blank screen) on other people's computers or in an Incognito window.

I have compared errors loading the application on both a normal and incognito browser and the main difference is the following error shown on the incognito browser "Uncaught Error: failed to load 'solutions/Component.js' from ../webapp/Component.js: 404 - Not Found".

Please see screenshots below for clarification and thank you so much for your efforts!

Not incognito mode - the Application loads (as you can see on the left panel) but numerous errors appear anyway?

Incognito window- does not load and has 1 major error added "Uncaught Error: failed to load 'solutions/Component.js' from ../webapp/Component.js: 404 - Not Found"

reply3.png (147.9 kB)
reply4.png (189.3 kB)
reply5.png (104.3 kB)
0
Jamie Cawley
Apr 11, 2017 at 02:50 PM
0

I just checked your page and it still showing

data-sap-ui-resourceroots="{"solutions": "../webapp/"}"

Make sure that your redeploy your changes and mark them as active.

Regards,

Jamie

SAP - Technology RIG

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Jamie,

If you are referring to line 15 in my index.html file, I believe I have changed it as you have suggested. But the application still does not load on incognito windows, while working on normal/non private browsers.

Please see screenshots and my index.html code for confirmation.

https://allsolutionsretry-i831410sapdev.dispatcher.int.sap.hana.ondemand.com/?hc_reset

<!DOCTYPE html>
<html>
	<head>
		<meta http-equiv="X-UA-Compatible" content="IE=edge" />
		<meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/>
		<meta name="viewport" content="width=device-width, initial-scale=1.0" />
		<title>All Solutions</title>


		<!-- Bootstrap the UI5 core library -->
		<script id="sap-ui-bootstrap"
				src="../resources/sap-ui-core.js"
				data-sap-ui-libs="sap.ushell, sap.collaboration, sap.m, sap.ui.layout"
				data-sap-ui-theme="sap_belize"
				data-sap-ui-compatVersion="edge"
				data-sap-ui-resourceroots='{"solutions": ""}'
				data-sap-ui-frameOptions='allow'> 	// NON-SECURE setting for testing environment
		</script>


			<script>
			sap.ui.getCore().attachInit(function() {
				new sap.m.Shell ({
					app: new sap.ui.core.ComponentContainer ({
						height: "100%",
						name: "solutions"
					})
				}).placeAt("content");
			});
		</script>


	</head>


	<!-- UI Content -->
	<body class="sapUiBody" id="content">
	</body>
</html>


replysure.png (81.0 kB)
replysure1.png (30.3 kB)
replysure.png (81.0 kB)
0

Still showing

data-sap-ui-resourceroots="{"solutions": "../webapp/"}"

Try deploying as a new application.

Regards,

Jamie

0