Skip to Content
avatar image
Former Member

Problem creating iOT Application on webide

Hi,

I'm trying to create an app on webide, from the iOT Application template. Everything runs smoothly until I get to the part where i'me supposed to select the property set Type and the property set. It tells me to select the property from the list but the list is empty.

Where are this properties defined?

In the previous wizard step I defined the following:

With the destination:

Do you have any idea what the problem might be?

thank you!

iot-problem.png (95.3 kB)
iot-problem2.png (35.6 kB)
iot-problem3.png (30.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Mar 31, 2017 at 06:11 PM

    Hello Fernando,

    you are using WebIDE plug-in for the IoT Application Enablement but try to feed it with OData Service exposed by SAP Cloud Platform Internet of Things (Message Management Service - iotmms).

    Please, follow this instructions [1] and create necessary destinations required by the IoT Application Enablement plugin.

    Regards,

    Anton

    [1] https://help.hana.ondemand.com/webide_iotapptemplates/frameset.htm?b11e8ace511c492693a16aaca082552d.html

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 03, 2017 at 08:42 AM

    Hello Anton,

    thank you for the reply.

    Do I need to configure all those tables(IOTAS-COMPOSITE-THINGS-ODATA, IOTAS-COMPOSITE, etc.) on the SAP CP destinations? To configure those destinations I need some credentials that are provided by sapiotappenablement@sap.com. I requested them last week but unfortunately didn't get any response so far.

    As for the service, I am using the oData Service exposed by SAP Cloud Platform so I guess that is not the problem.

    cheers

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 14, 2017 at 04:06 PM

    hey fernando

    You could solve the problem?? if yes how???

    thank you

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 15, 2017 at 10:05 AM

    Hi Fernando

    Can you please share how your problem was resolved on this topic ?

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 29, 2017 at 09:59 AM

    Please also make sure you cover the trust configuration described at https://blogs.sap.com/2017/10/24/trust-configuration-between-sap-cloud-platform-neo-account-and-sap-iot-application-enablement/ (official documentation is at help.sap.com > SAP IoT Application Enablement > SAP IoT Application Enablement Reuse Controls and Templates > IoT Application Projects in SAP Web IDE > Prerequisites > Configuring SAML Trust between Neo Environment and Cloud Foundry Environment)

    Add comment
    10|10000 characters needed characters exceeded