Skip to Content
avatar image
Former Member

ERROR service 'sapmsBCD' unknown

I have installed the third release of Argo's preview....and am having difficulty getting it to work.

I read the previous comments by Kai, regarding the SES / BAPI configuration in the install wizard. I understand gateway host is supposed to be the message server and the R3 Name is the commonly referrerd to Instance initials.

In the Gateway-host field I have entered a series of different values, none of which were successful. Any assistance getting this thing set up would be appreciated.

Here are some of the values I have tried

In the Logon Group: "SPACE", "PUBLIC", empty

In the Gateway-host field I tried using message server connection and app server connections, below I list the variation for each:

Message Server

IP address(with Port)###.###.###.###:####

IP address(without Port) ###.###.###.###

Connection String

/M/###.###.###.###/S/####/G/SPACE

/M/###.###.###.###/S/####

Application Server

IP address(with Port)###.###.###.###:####

IP address(without Port) ###.###.###.###

Connection String

/H/###.###.###.###/S/####/G/SPACE

/H/###.###.###.###/S/####

I get the following error consistantly:

********************************************************

Error during searching Qualification:

Fail to init client by SIDConnect to message server host failed

Connect_PM TYPE=B MSHOST=###.###.###.###:#### GROUP=SPACE R3NAME=BCD MSSERV=sapmsBCD PCS=1

ERROR service 'sapmsBCD' unknown

TIME Tue Oct 10 11:59:29 2006

RELEASE 710

COMPONENT NI (network interface)

VERSION 39

RC -3

MODULE nixxhsl.cpp

LINE 643

DETAIL NiHsLGetServNo: service name cached as unknown

COUNTER 1

Error during searching Person:

Fail to init client by SIDConnect to message server host failed

Connect_PM TYPE=B MSHOST=###.###.###.###:####GROUP=SPACE R3NAME=BCD MSSERV=sapmsBCD PCS=1

*********************************************************

Is there something I am missing?

Message was edited by: Ryan Quackenboss

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 11, 2006 at 01:24 PM

    Hi Ryan,

    To connect to the BAPI the SAP J2EE engine uses system services described in the <windows>/system32/drivers/etc/services.

    The name of the service is calculated as 'sapms<SID>'. You have to do this entry manually on your Argo machine.

    the entry for the mentioned BCD system:

    sapmsBCD 6540/tcp

    Regards,

    Kai

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Some hint how to find the correct values (worked for me, is no official information):

      sapms<System-ID> 3600/tcp # For JCo Desination. <System-ID> of the target system, port 3600 is its message server port (can be found e.g. in SLD / Technical Systems)