Skip to Content
0

Crystal Reports Assembly dll CrystalDecisions.ReportAppServer.CommLayer not found

Mar 31, 2017 at 07:26 AM

147

avatar image
Former Member

Hi,

We recently changed all our computers in our company from Windows 7 to Windows 10, completely new installations. I made a program back in 2013 which prints different Crystal Reports Documents. Now I need to get this program working again.

I've installed CR for Visual Studio 2010 version 19 (the most recent I believe) and tested my program. It works perfect.

I updated my installer project to install my updated program on the client computers. On the Client computers I first installed the Crystal Reports runtime (also version 19). Then I installed my program.

Now when I run my program it gives me the following error message:

The details of the error are like this (translated from dutch):

System.TypeInitializationException: De type-initialisation function for CrystalDecisions.CrystalReports.Engine.ReportDocument has caused an exception. ---> System.IO.FileNotFoundException: Can't load file or assembly CrystalDecisions.ReportAppServer.CommLayer, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304 or one of it's dependancies. The system can't find the file.

When I check the GAC on the client PC I noticed that indeed this assembly is not there. I checked my own computer and I do have this assembly in my GAC so that's why it's working for me. I tried to copy manually the assembly from my GAC to the GAC of the client computer, but that didn't work. It gave me the message that the version was wrong. So I removed the assembly in the GAC of the client computer

Then I checked the references of my project in Visual studio to see that I could add this missing assembly (CrystalDecisions.ReportAppServer.CommLayer.) in my installer. I added it to my references but I received a warning that it was embedded in CrystalDecisions.CrystalReports.Engine. I resolved it to set Embed Interop Type to false for CrystalDecisions.ReportAppServer.CommLayer. I also changed Copy Local to True for all the references from Crystal Reports. This didn't worked either, because I received the same error message as shown above.

I don't know what I can do to make this work. Can you help me here?

naamloos.jpg (36.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers