Skip to Content
avatar image
Former Member

Purchase Requisitions stuck in CPP

Hi,

Every week we do CCR and CPP between APO and R/3. Once CCR is completed, we check the CPP to process stuck transactions. I am able to see few External Procurement (Object in R/3 = Purchase Requisition) stuck in CPP and if I check the related error in R/3 in SLG1 Tcode then I am getting error - 'Inbound R/3: No IModel active for cat. Purchase orders and purch.reqs, filter object Mat1234 Location12 for system APOSYSTEM'.

If I check the material details in APO in /sapapo/mat1 , this material Mat1234 for location Location12 is flagged for deletion' and in RRP3 it doesn't have any Purchase requisitions. I have many cases like this.

My question is, why even though there is no purchase requisition present for this product - location combination in rrp3, how PR entry present in CPP?

and How to fix this issue.

Please help.

Thanks in Advance

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 05, 2017 at 09:23 PM

    Hello Padmaprasad,

    At the Product View, in Settings -> User Settings -> Orders tab, you may set the flag "Display External Procurement Element With Qty 0" - it's possible some purchase orders still exist (with quantity 0), which much be deleted. You may as well execite WUF transaction for the affected Location Product to see whether it points to any remaining orders which may exist.

    This issue can happen if at the time the orders were created in APO there was no active integration model for the Location-Product. The queues got stuck on /SAPAPO/CPP, and afterwards the deletion flag was set for the Location-Products, such that the entry in CPP remains even though the product has been marked for deletion. If that is the case, you may set status obsolete for the queue in cif post processing so it will not appear anymore.

    Regards,
    Tiago

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tiago,

      Thanks for the reply. I have checked the details and I don't see the setting- Display External Procurement Element With Qty 0.
      However I can see there are few orders shown in WUF which are bit old.

      I will check further and come back if I need any further details.