Skip to Content
0

isql login problem

Mar 30, 2017 at 05:56 PM

88

avatar image
Former Member

The O.S is Sun Solaris 5.10

Sybase ASE 15.7

$SYBASE_ASE and $SYBASE_OCS are set correctly, including settings (interfaces)

This is a new server with the Sybase. Whenever a login with isql -Usa -Sservername-(optional) is tried, it comes with the error message below. However, it does login occasionally taking a long time.There are no entries in the error log file. The settings are similar and functional on other servers.

CT-LIBRARY error:ct_connect(): user api layer: internal Client Library error: Read from the server has timed out.

CT-LIBRARY error: ct_connect(): user api layer: internal Client Library error: Read from the server has timed out.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

avatar image
Former Member Mar 30, 2017 at 08:03 PM
0

Verify:

1. $SYBASE/interfaces file, must be properly configured, or,

2. Run the "DHCP" tool and verify the connection data to ASE.

3. Verify that the environment variables are correct. Test - for example - echo $SYBASE, you see the installation path of SYBASE.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

It seems that your suggestions were already checked. Could you kindly respond with more suggestions?

0
avatar image
Former Member Mar 30, 2017 at 10:26 PM
0

Thank you for the quick response Aurello,

As mentioned earlier, $SYBASE_ASE and $SYBASE_OCS are set correctly, including settings (interfaces). The interfaces file and environment variables had been checked. The sybase is up and running. Could you please enumerate the DHCP tool you have mentioned. The network connectivity has been checked. am also sending an output of the server listing.

UID PID PPID C STIME TTY TIME CMD preccp01 4867 4864 0 Mar 27 pts/2 0:00 /SYBASE/preccp01/sybhome/ASE-15_0/bin/backupserver -e/SYBASE/preccp01/sybhome/A

preccp01 4848 4840 0 Mar 27 ? 115:46 /SYBASE/preccp01/sybhome/ASE-15_0/bin/dataserver -d/SYBASE/preccp01/sybhome/../

The sybase ASE and even the backup server is starting without issues.

preccp01 4848 4840 0 Mar 27 ? 116:16 /SYBASE/preccp01/sybhome/ASE-15_0/bin/dataserver -d/SYBASE/preccp01/sybhome/../

Could you kindly respond with more suggestions.

Regards

Aravind Diwakar

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 31, 2017 at 02:29 PM
0

Do you run "isql" on server or from a client?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 31, 2017 at 02:38 PM
0

I ask you, excuse me, it's not DHCP is DSCP ...

DSCP is the UNIX equivalent to DSEDIT in WINDOWS ...

on unix:

$> dscp

>> open

>> list

list all ASE SERVER with connections

close

>> exit

$>

See: Adaptive Server Enterprise 15.7 > Utility Guide 15.7 > Utility Commands Reference

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

If this could possibly be a networking or a O.S error, will need to make sure it is not a database issue (please suggest). Thank you

0
avatar image
Former Member Mar 31, 2017 at 07:06 PM
0

Thanks for the responses Aurello:.

1) The isql is run on the server after connecting to it remotely.

2) Had already checked the dscp and it is listed!!

3) Also, had checked ulimit -a.

There are similar live servers that are working well.

Share
10 |10000 characters needed characters left characters exceeded