Skip to Content
avatar image
Former Member

sap.ui5 has additional properties manifest error.

{
    "_version": "1.2.0",
    "sap.app": {
    "_version": "1.2.0",
    "id": "pricereview",
    "type": "application",
    "i18n": "i18n/i18n.properties",
    "title": "{{appTitle}}",
    "description": "{{appDescription}}",
    "applicationVersion": {
    "version": "1.0.0"
    },
    "dataSources": {
    "mainService": {
    "uri": "/sap/opu/odata/stl/GWP_PRICE_REVIEW_SRV/",
    "type": "OData",
    "settings": {
    "odataVersion": "2.0",
    "localUri": "localService/metadata.xml",
    "annotations": [
    "DetailViewAnnotations"
    ]
    }
    },
    "DetailViewAnnotations": {
    "uri": "../annotations.xml",
    "type": "ODataAnnotation",
    "settings": {
    "localUri": "../annotations.xml"
    }
    }
    },
    "sourceTemplate": {
    "id": "sap.ui.ui5-template-plugin.1worklist",
    "version": "1.44.6"
    }
    },
    "sap.ui": {
    "_version": "1.2.0",
    "technology": "UI5",
    "icons": {
    "icon": "sap-icon://task",
    "favIcon": "",
    "phone": "",
    "phone@2": "",
    "tablet": "",
    "tablet@2": ""
    },
    "deviceTypes": {
    "desktop": true,
    "tablet": true,
    "phone": true
    },
    "supportedThemes": [
    "sap_hcb",
    "sap_belize"
    ]
    },
    "sap.ui5": {
    "_version": "1.2.0",
    "rootView": {
    "viewName": "pricereview.view.App",
    "type": "XML",
    "id": "app"
    },
    "dependencies": {
    "minUI5Version": "1.36.0",
    "libs": {
    "sap.ui.core": {
    "minVersion": "1.36.0"
    },
    "sap.m": {
    "minVersion": "1.36.0"
    },
    "sap.ui.layout": {
    "minVersion": "1.36.0"
    },
    "sap.ushell": {
    "minVersion": "1.36.0"
    }
    }
    },
    "contentDensities": {
    "compact": true,
    "cozy": true
    },
    "models": {
    "i18n": {
    "type": "sap.ui.model.resource.ResourceModel",
    "settings": {
    "bundleName": "pricereview.i18n.i18n"
    }
    },
    "": {
    "dataSource": "mainService",
    "preload" : true
    }
    },
    "services": {
    "ShellUIService": {
    "factoryName": "sap.ushell.ui5service.ShellUIService",
    "lazy": false,
    "settings": {
    "setHierarchy": "auto",
    "setTitle": "auto"
    }
    }
    },
    "routing": {
    "config": {
    "routerClass": "sap.m.routing.Router",
    "viewType": "XML",
    "viewPath": "pricereview.view",
    "controlId": "app",
    "controlAggregation": "pages",
    "bypassed": {
    "target": [
    "notFound"
    ]
    },
    "async": true
    },
    "routes": [
    {
    "pattern": "",
    "name": "worklist",
    "target": [
    "worklist"
    ]
    },
    {
    "pattern": "EtyPriceReviewCollection/{objectId}",
    "name": "object",
    "target": [
    "object"
    ]
    }
    ],
    "targets": {
    "worklist": {
    "viewName": "Worklist",
    "viewId": "worklist",
    "viewLevel": 1,
    "title": "{i18n>worklistViewTitle}"
    },
    "object": {
    "viewName": "Object",
    "viewId": "object",
    "viewLevel": 2,
    "title": "{i18n>objectViewTitle}"
    },
    "objectNotFound": {
    "viewName": "ObjectNotFound",
    "viewId": "objectNotFound"
    },
    "notFound": {
    "viewName": "NotFound",
    "viewId": "notFound"
    }
    }
    }
    }
    }

hi experts, I'm facing this error in my manifest.json file. It says "sap.ui5"- has additional properties" Please tell me what is the error. Thanks in advance

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • May 08, 2017 at 09:11 AM

    When I remove the _version attribute from "sap.ui5": {...

    then the:"sap.ui5"._version- is required error is shown.

    When I change the _version into 1.4.0 then the problem is solved :

    "_version": "1.4.0", "sap.app": { ....

    Furthermore the "_version" attribute is not required anymore, so the _version attribute can be removed from the other tags.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 18, 2017 at 03:03 PM
    -1

    Hello ,

    The issue is because of the attribute _version under sap.ui5 namespace. Specifically this

    {
      "sap.ui5": {
        "_version": "1.2.0",
        "rootView": {
          "viewName": "pricereview.view.App",
          "type": "XML",
          "id": "app"
        },
        "dependencies": {
          "minUI5Version": "1.36.0",
          "libs": {
            "sap.ui.core": {
              "minVersion": "1.36.0"
            },
            "sap.m": {
              "minVersion": "1.36.0"
            },
            "sap.ui.layout": {
              "minVersion": "1.36.0"
            },
            "sap.ushell": {
              "minVersion": "1.36.0"
            }
          }
        },
        "contentDensities": {
          "compact": true,
          "cozy": true
        },
        "models": {
          "i18n": {
            "type": "sap.ui.model.resource.ResourceModel",
            "settings": {
              "bundleName": "pricereview.i18n.i18n"
            }
          },
          "": {
            "dataSource": "mainService",
            "preload": true
          }
        },
        "services": {
          "ShellUIService": {
            "factoryName": "sap.ushell.ui5service.ShellUIService",
            "lazy": false,
            "settings": {
              "setHierarchy": "auto",
              "setTitle": "auto"
            }
          }
        },
        "routing": {
          "config": {
            "routerClass": "sap.m.routing.Router",
            "viewType": "XML",
            "viewPath": "pricereview.view",
            "controlId": "app",
            "controlAggregation": "pages",
            "bypassed": {
              "target": [
                "notFound"
              ]
            },
            "async": true
          },
          "routes": [
            {
              "pattern": "",
              "name": "worklist",
              "target": [
                "worklist"
              ]
            },
            {
              "pattern": "EtyPriceReviewCollection/{objectId}",
              "name": "object",
              "target": [
                "object"
              ]
            }
          ],
          "targets": {
            "worklist": {
              "viewName": "Worklist",
              "viewId": "worklist",
              "viewLevel": 1,
              "title": "{i18n>worklistViewTitle}"
            },
            "object": {
              "viewName": "Object",
              "viewId": "object",
              "viewLevel": 2,
              "title": "{i18n>objectViewTitle}"
            },
            "objectNotFound": {
              "viewName": "ObjectNotFound",
              "viewId": "objectNotFound"
            },
            "notFound": {
              "viewName": "NotFound",
              "viewId": "notFound"
            }
          }
        }
      }
    }
    
    

    The version should be outside which is in the initial question. But the version inside the sap.ui5 is wrong. Remove that attribute and it should fix the issue.

    Thanks and Regards,

    Veera

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 18, 2017 at 05:01 AM

    Hi,

    I am facing a similar error.

    Anybody can help , it would be useful.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 07, 2017 at 03:08 PM

    if there is any unlisted root file mentioned in root view it's gonna cause such issue so simply remove unwanted path or file in root view.it will be cleared

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 04, 2017 at 03:44 PM

    I am facing the same issue when adding following piece of code :

    "dataSources":

    { "ES4":

    { "uri": "/destinations/ES4/sap/opu/odata/IWBEP/GWSAMPLE_BASIC/", "type": "OData",

    "settings": { "odataVersion": "2.0"

    }

    }

    },

    Anyone please hlep ?

    Thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 20, 2017 at 07:07 AM

    The component factory function sap.ui.component enables you to load the manifest.json before the component instance is created. With this, you can preload the dependencies (libraries and components) and, thus, improve the performance for loading the component. The preload is also available for models, which can be flagged for preload during component loading.

    To enable this so-called “manifest first” function, you can choose one of the following options:

    • Set the manifestFirst flag to true.
    • Specify a manifestUrl as parameter for the component factory function:
    // load via manifestFirst option
    sap.ui.component({
      name:"sap.my.component",
      manifestFirst:true});//load via manifestUrl
    sap.ui.component({
      name:"sap.my.component", 

    manifestUrl:"any/location/sap/my/component/manifest.json"});

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 23 at 02:28 AM

    You can also recreate the file. Sometimes this issue will go away.

    Add comment
    10|10000 characters needed characters exceeded