Skip to Content

Live Office ignoring WebI prompt (SAP BI 4.2 SP3 PL5 )

Dear experts

We are currently planning an update from BI 4.1 SP3 P2 to BI 4.2 SP3 P5. During tests on our sandbox system we discovered that Live Office seems to ignore the WebI prompt. We didn't find out until now what the problem is.

If you refresh the WebI report everything works. The prompt appears and the report is selecting the data correctly based on the given criteria. When we use the Live Office report the prompt will not appear. It directly displays the loading progress bar. Finally it just displays the report as it is saved within the repository (no data refresh at all).

If I create a new Live Office report based on that specific WebI report I see the WebI prompt. But Live Office just ignores my input and loads all the data possible instead.

Anybody experienced similar behavior?

Thanks in advance
Lars

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Apr 22, 2017 at 06:04 PM

    Hi Lars,

    Is your problem resolved? I am facing some issue related to webi prompts.

    Thanks
    Deepti

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Deepti

      I just got an answer from SAP today. See the conclusion of the analysis below:

      "It seems like any WebI report which is having optional prompt is not in working in BI 4.2 SP3 Patch 5".

      I was able to reproduce the error with optional checkbox ticked. When the query filter is not set to optional everything seems to work fine.

      Regards
      Lars

  • avatar image
    Former Member
    Nov 28, 2017 at 02:54 PM

    Hi all,

    i have the same issue. When i try to import the webi into an axcel file, no prompts asked and live office imports no data.

    Only header but no data.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 28, 2017 at 07:22 PM

    Hi All,

    The best practise is to open excel document first and insert all the Live office connection and refresh it once. and then Xcelsius and import the excel in which you have included Live connection earlier . After bind all the prompts and refresh it and check whether it is working fine or not.

    Regards,

    Anish

    Add comment
    10|10000 characters needed characters exceeded