Skip to Content

SAPUI5 version in HANA Express?

Hi,

I'm trying to make some proof of concept with HANA 2 Express VM, using a XSC oData service. I'm having problems with the binding, as it doesn't seem to work. I defined the datasources in the manifest.json, as I have done in the past but with no luck.

Checking the version of UI5, it seems to be 1.28.39, quite old. I know that version 1.30 introduced some changes in the way the manifest.json is treated. Does anyone knows why the UI5 included in the latest Express version is so old?

Can I retrofit a more current one?

Thanks!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Apr 08, 2017 at 05:06 PM

    Please check the discussion (also the comments) in post https://answers.sap.com/questions/169040/hana20-express-sapui5-1-missing-sapmsemantic-packa.html. For XS classic there are not updates planned so far for the UI5 version (at the moment it will stay at 1.28). If you wanna benefit from the newer vesions of UI5 you have to switch to XSA or use the version from the public CDN.

    Regards,
    Florian

    Add comment
    10|10000 characters needed characters exceeded