Skip to Content
author's profile photo Former Member
Former Member

Getting error in target SOAP communication channel

Hi all,

I am trying to send data from Http client to Webservice.In moni i got a message processed successfully means getting black flag.But i got an error in SOAP Communication channel as "error in response".

I got this message from that error

<b>"SOAP: response message contains an error XIAdapter/HTTP/ADAPTER.HTTP_EXCEPTION - HTTP 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied. )"</b>

Source side i dont configure Http adapter.Target side i configured SOAP adapter.In that SOAP adapter i configured these fields.1)Target URL 2)Configure Proxy 3)Configure proxy user authentication.

I want get response from webservice.Please help me.

Thanks,

Gopi.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 03, 2006 at 04:49 AM

    Hi,

    Make sure that you have specified the proper host and port values, in the text box that appears when you check the configure proxy check box(in receiver soap adapter).

    Looks like the webservice requires a proxy authentication.

    Select the check box "configure proxy user authentication"(in receiver soap adapter) and provide the correct username and password.

    Regards,

    Smitha.

    Message was edited by: Smitha Rao

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Check sxi_monitor for your request and response.

      Is the response from the webservice actually coming back?

      Try getting one of the fields from the response, as the output in the http client(rather than a hardcoded output), to make sure, the sync communication is working fine.

      Regards,

      Smitha.

  • Posted on Oct 03, 2006 at 04:51 AM

    Hi,

    Check the configure user authentication check box below your target url tab and provide the username and password.

    Regards,

    Chandra

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 03, 2006 at 04:52 AM

    Hi,

    Check the proxy authentication.

    If it is still not working, try deleting and

    creating the channel again.

    Rgds,

    Chemmanz

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.