Skip to Content
0

SAP not starting on Windows 2008

Mar 29, 2017 at 12:49 PM

158

avatar image
Former Member

Hi Experts!

We are performing an EHP upgrade on Windows but we are getting error in Phase: MAIN_NEWBAS/STARTSAP_NBAS

SUM can't start Instance:

Please seee below error

dev_disp:

Wed Mar 29 08:48:00 2017 ***LOG Q0I=> NiPConnect2: 172.16.2.68:3909: connect (10061: WSAECONNREFUSED: Connection refused) [nixxi.cpp 3283] *** ERROR => NiPConnect2: SiPeekPendConn failed for hdl 17/sock 904 (SI_ECONN_REFUSE/10061; I4; ST; 172.16.2.68:3909) [nixxi.cpp 3283] *** ERROR => MsIAttachEx: NiBufConnect to SPBPIPVM01/3909 failed (rc=NIECONN_REFUSED) [msxxi.c 718] ***LOG Q0L=> DpLoopInit, nomscon () [dpxxdisp.c 1803] CCMS: SemInMgt: Initializing Semaphore Management in AlAttachShm_Doublestack. CCMS: SemInit: Semaphore 38 initialized by AlAttachShm_Doublestack. CCMS: start to initalize 3.X shared alert area (first segment). DpAppcBlksLow: max appc blocks in queue is 500 (50 %)

dev_w0:

Wed Mar 29 08:48:17 2017 N SignInit: successfully obtained handle for Security Context cache N SPNegoInit: SPNego disabled ("spnego/enable" not set to 1) N VSI: WP init in ABAP VM completed with rc=0 E EnqId_Initialize: local EnqId initialization o.k. M Set restart flag on 1073741824 bytes os heap B B Wed Mar 29 09:04:20 2017 B dbsync[db_syexe]: { wait=0, call_no=7, current_ts=20170329090420, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:06:20 2017 B dbsync[db_syexe]: { wait=0, call_no=8, current_ts=20170329090620, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:08:20 2017 B dbsync[db_syexe]: { wait=0, call_no=9, current_ts=20170329090820, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:10:20 2017 B dbsync[db_syexe]: { wait=0, call_no=10, current_ts=20170329091020, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:12:20 2017 B dbsync[db_syexe]: { wait=0, call_no=11, current_ts=20170329091220, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:14:20 2017 B dbsync[db_syexe]: { wait=0, call_no=12, current_ts=20170329091420, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0 B B Wed Mar 29 09:16:20 2017 B dbsync[db_syexe]: { wait=0, call_no=13, current_ts=20170329091620, last_counter=8 B dbsync[db_syexe]: } rc=0, most_recent_sync=8, rec_cnt=0, request_cnt=0

dev_rd:

Wed Mar 29 08:48:00 2017 DpCommAttachTable: attached comm table (header=00000000143F2BB0/ft=00000000143F2BC0) MtxInit: -2 0 0 DpRqQInit: use protect_queue / slots_per_queue 0 / 2001 from sys_adm Wed Mar 29 08:48:14 2017 GwDpInit: attached to gw_adm at 0000000014558380 Wed Mar 29 08:52:01 2017 ***************************************************************************** * * LOCATION SAP-Gateway on host SPBPIPVM01.domain.com. / sapgw09 * ERROR connection to partner 'SPBPIPVM01:58500' broken * * TIME Wed Mar 29 08:52:01 2017 * RELEASE 722 * COMPONENT NI (network interface) * VERSION 40 * RC -6 * MODULE nixxi.cpp * LINE 4845 * DETAIL NiIRead: P=172.16.2.68:58500; L=172.16.2.68:3309 * SYSTEM CALL recv * COUNTER 1 * ***************************************************************************** GwTraceHdlInfo: handle = 57 HANDLE = 57 TIME = Wed Mar 29 08:51:50 2017 SOCKET = 440 STAT = NI_ACCEPTED TYPE = STREAM IPv4 OUT = 0 messages 0 bytes IN = 0 messages 0 bytes LOCAL = 172.16.2.68:3309 REMOTE = 172.16.2.68:58500 OPTIONS = type = NORMAL_CONNECT net_stat = CONNECT_PENDING_READ hostaddr = 172.16.2.68 accept_hostaddr = 172.16.2.68 opcode = UNDEF_TYPE conn opcode = 32 conn vers = 34 index = -1 data = 0000000013C40900 ext_info = 0000000000000000 offset = 0 rest_len = 10000 snc_forced = 0 last req = Wed Mar 29 08:51:57 2017

Thanks for any help

errorsap.png (3.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Bartosz Jarkowski Mar 29, 2017 at 01:32 PM
1

Hi,

is you ASCS instance up? Can you please paste dev_ms?
I assume you already checked firewall etc :)
Can you try to telnet to your host on port 3909?

Best regards

Bartosz

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi, Bartosz

I checked the profile instance and i don't know why but SUM created this entries with wrong value:

i changed to correct port and now is working..

Thank you!

screenshot-1.png (3.5 kB)
0
Raquel Gomez
Apr 03, 2017 at 12:25 PM
0

Hi,

Screenshot shows disp+work in yellos stauts due to reason "Running but Message Server unreachable".
Same error is traced on dev_disp:
Wed Mar 29 08:48:00 2017
***LOG Q0I=> NiPConnect2: 172.16.2.68:3909: connect (10061: WSAECONNREFUSED: Connection refused) [nixxi.cpp 3283]
*** ERROR => NiPConnect2: SiPeekPendConn failed for hdl 17/sock 904 (SI_ECONN_REFUSE/10061; I4; ST; 172.16.2.68:3909) [nixxi.cpp 3283]
*** ERROR => MsIAttachEx: NiBufConnect to SPBPIPVM01/3909 failed (rc=NIECONN_REFUSED) [msxxi.c 718]
***LOG Q0L=> DpLoopInit, nomscon () [dpxxdisp.c 1803]

You should check which was Message Server status at that timestamp (March 29th).
Is it up and correctly running? Listening on 3909 port?

Regards,
Raquel

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Raquel,

The port 3909 was wrong!

Thank you.

0

Hi Antilhas,

Great that issue was solved after fixing MS port.

Regards,
Raquel

1