Skip to Content
1

VBAP table activation taking forever - unable to add new fields

Mar 29, 2017 at 05:01 AM

148

avatar image
Former Member

Hi Experts,

We are facing a strange issue while adding new fields to VBAP table via append structure. After adding new fields and clicking ACTIVATE, it goes into wait mode (probably hang mode), we had waited for 15-16 hours, then had to kill the process.

  • New fields in append structure are simple CHAR fields.
  • New Z Structure name is provided such that these fields will be in the end of table and not in the middle of existing fields.
  • This is happening in DEV (not related to PRD or Transports etc)
  • SE14 (adjust database) step is after activation, but here issue is in activation itself
  • Runtime and database objects are all consistent before trying to add the fields
  • Table fields length doesn't exceed max limit of 4030 char
  • There are 9 custom append structures already in table (with our custom fields), I though it can be due to max limit of 9 append in any table, but tried on a customer transparent table (ZXYZ) and able to add more than 9 append structures easily
  • Data in our VBAP table is huge (30 million) but that shouldn't be reason of activation problem
  • Basis team also cannot find anything unusual database side for VBAP table

Please suggest what else can be tried out. Is there a possible way that new fields can be added by basis team at database level directly (using alter table), will it work, how to transport it ?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Rob Dielemans Mar 29, 2017 at 09:26 AM
1

Hi,

Ask basis to check if this is a memory/sizing issue. Either the specs of the dev system is low or the allocation to dialog processes is low.

Oh and check OSS there are notes on this subject.

Kind regards, Rob Dielemans

Share
10 |10000 characters needed characters left characters exceeded
Matthew Billingham
Mar 29, 2017 at 08:29 AM
0

I was going to suggest that you talk to Basis as this is most likely a database issue. However, you've done that, so I think your only recourse is to report to SAP and have them have a look.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Matthew for response, yes we have already raised an incident to SAP today morning, waiting for their response as well.

0
avatar image
Former Member Mar 29, 2017 at 09:48 AM
0

Is SE14 - activate and adjust in background mode not working as well?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Isn't that suppose to work only after activation

0
avatar image
Former Member Mar 30, 2017 at 01:12 AM
0

Yeah Rob, I was also counting on basis but unfortunately they couldn't find anything :(

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 30, 2017 at 01:37 AM
0

Any other tips which can be tried....or maybe some detailed steps which we can ask Basis team to try out

Share
10 |10000 characters needed characters left characters exceeded