Skip to Content
author's profile photo Former Member
Former Member

2005 SP01 PL09; mandatory Add-On; logon w/o company change => SBO crashes

Hello,

We installed an add on at a customer site. The Add on is set to start up automatically whenever a user logs in to Business One. To ensure a user cannot start SBO without our add on we set the Add on default group to mandatory.

We recently upgraded from sbo 2005 sp 1 pl7 to sbo 2005 sp 1 pl 9. Now every time we bring up Business One and log into a company directly from the sign in screen the Add on crashes and then Business One crashes.

If we click change company on the log in screen and then select the company via a click we can log in successfully.

I think that this might have something to do with the new security feature that forces the user to retype the password every time they change company.

Has anybody else encountered this error when upgrading to pl 9?

Message was edited by: Frank Moebius

I thought it might be helpful to put the subject a bit more specific...

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 27, 2006 at 03:44 PM

    Hi,

    I tried to reproduce the issue on PL09, but I failed - i.e. everything worked!

    Did you try to check with .NET Profiler to eventually get a clue what might go wrong?

    Did you recompile your Add-On on PL09 - just to make sure?

    Maybe someone else came across this issue too...?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Here is what I've found:

      If I set my SQL Server preferences to login using trusted connection and attempt to login to my company from the login screen both my add on and Business one crash.

      If I set my SQL server preferences to login using SQL username and password and attempt to login to my company from the login screen my add on and Business one start up OK.

      If I try and login from the change company screen regardless of the SQL Server preferences I don't have a problem.

      Any idea on why this happens?

      Note: I am using SQL Server 2005.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.