Skip to Content
avatar image
Former Member

Cristal Report for Visual Studio - Reports Crystal Report impossible to open

Goodmorning everyone,

my name is Alessandro and I have a problem to submit.

In this period we bought a new server, a Dell PowerEdge, on which we have started to porting of the entire business environment. Porting includes, among other things, set up sites on IIS designed in C # as a Web App using Visual Studio and SQL Server DB.

We have, internally, the Microsoft Partner Program, through which I have carried out the installation of Windows Server 2016 Standard, as well as the roles and key features for us (ASP.NET 3.5, 4.5, Remote Desktop Services, IIS, etc.).

I brought in the new environment DB, projects, configured ODBC, creating sites on IIS with DefaultAppPool and configured with a DNS on Aruba that pointed on the site so it is possibile to see it from the outside and test its functioning.

At which point I installed Visual Studio 2015 (for 2017 did not exist CRforVS yet), Cristal Report 2011 (the only version we have available) and the latest release of Crystal Reports for Visual Studio from the site SAP (the 19.0, which should have the compatibility with Windows Server 2016).

At this point I tried to open the site from the third level; everything worked, including AJAX (although in recent versions of VS Some tools have become obsolete) but if I try to open a CR report that gives me the error that the image I'm attaching.

The connection between CR and VS is always a bottle neck every time we make a migration, but usually CRforVS and the libraries in the solution taken from NuGet solve the problem.

This time there's no way.

By chance, that you know, is a problem of compatibility with Windows Server 2016?

Or do I have to run the application with a Pool different, a different version of ASP.NET, and then build the solution with, for example, 4.5?

Or it can be a path problem file?

Many thanks in advance!

Cordially,

Trezzi Alessandro

1031881.png (127.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Mar 28, 2017 at 01:29 PM

    Hi Trezzi,

    The error says it can't find the report, make sure IIS has full permissions where the report is being loaded from.

    I believe also Microsoft doesn't support 4.5 framework, you may need to upgrade to 4.6.

    Also, security changes require you to load the report in the Page_Init section and not the Page_Load section now.

    You also need to use Sessions and Postback to keep the report in scope.

    Search for KBA 1985571

    1985571 - How to use sessions in web applications using the Crystal Reports viewer (the complete code)

    If you have access to SMP then the link works otherwise search for the number only.

    Also, look in this location:

    C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319\crystalreportviewers13

    Delete any of the ASPX, asp etc., only files that should be in there are *.js files.

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 28, 2017 at 09:52 PM

    Hi Don,

    thank's a lot for your answer, I will try as soon as possible all your solutions (I've forgot to manage IIS_IUSRS permissions on project path).

    For the framework version you mean the one in project or in the Operative System?

    For what regards instead Sessions we always develop with those method, generating Sessions containing path and WHERE filter passed in variables and call the report in this way.

    I also will look the cristalreportviewer13 and his content.
    For what regards the aspnet_client folder, you mean the one in the web app project? I also have other sub folder besides the 4_0_30319 one (3_ or 2_, I don't remember); I have to delete those too, remaining only with the 4_ one?

    Thank's a lot,

    Alessandro

    Add comment
    10|10000 characters needed characters exceeded