Skip to Content
author's profile photo Former Member
Former Member

no field group was selected in the blueprint

hi,

i used eewb to add some custom fields to lead appication.

1.it was successfully added to thelead transaction in gui.

2.i checked the appended fields in pcui screen structure

i.e. crmt_bsp_lea_overview.

i checked the

3.And there is also include which contains my fields.

4.I created one new field group i.e zlead.(in crmc

-blueprint_c). assigned screen structure crmt_bsp_lea_overview.

5.i filled this group with fields as per Tiest blog.

6.i created second field group(zlead_detail) assigned screen structure

crmt_bsp_lea_overview.

7.In zlead_detail, i enter zlead is reference group and as screen group.

8.when i generate zlead and zlead_detail.

it is giving error no field group is selected from blue print table.

how can i rectfy it.

thanks.

swathi

7.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 24, 2006 at 05:41 PM

    Swati, in a previous forum item I answered a similar question. Let me explain first the fundamentals of the PC-UI Framework. By adding your custom fieldgroups entries are created in the CRMC_LAYOUTC tables and CRMC_LAYOUT tables after you have successfully generated the corresponding layout. Since your custom field must work with in the existing framework the corresponding blueprint tables must contain the correct entries in order to process correctly.

    Let's go to the steps:

    1 - Check layout for your fieldgroup (tcode: CRMC_LAYOUTC_GENE) and enter your field group name, leave check boxes as is and view result.

    2 - If successfull you have uncheck the checkbox and run the generation again. At this point the missing entry is being generated.

    3 - If unsuccessfull I would think you either did not make your fieldgroups known in your application AND assign the application to your application set.

    4 - Return to step one and you should be fine.

    Kind regards, Tiest.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.