Skip to Content
0

S/4 HANA 1610 - Could not open App. Please try again - UtilityHelper.js 404 Not Found

Mar 27, 2017 at 07:14 PM

630

avatar image

Hello,

I am facing an issue while using Fiori 2.0 apps based on S/4 HANA 1610 FPS01. When I click on App tile called "Manager Sales Order", it gives an error as Could not open App. Please try again.

So I opened Google Chrome Developer Tools and under Network Tab, I found it is not able to load one of the file which is UtilityHelper.js and giving as 404 NOT FOUND error.

Please find attachments.

If you ever came across this scenario, I need help.

app-problem.png (38.7 kB)
capture.png (6.6 kB)
10 |10000 characters needed characters left characters exceeded

Hi, Ankur.

I'm not convinced the 404 on UtilityHelper.js is the cause of your error. Could you provide the browser's console log from when you try to open the app? Also, please let me know if this app has ever worked? Thanks.

Keith Nunn
SAP Product Support

0

Hi @Keith,

Problem was solved after installing few components. Sorry for delay in response.

Thanks

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Jocelyn Dart
Mar 29, 2017 at 08:55 AM
0

Hi Ankur

"Could not open app" is a very common error which typically means you are missing something, e.g.

  • A dependent OData service is not active
  • A reuse component is not active
  • Some foundation configuration to active very common reuse components has not been completed
  • Authorizations are missing

Firstly check the App Implementation details in the Fiori Apps Library

https://fioriappslibrary.hana.ondemand.com/sap/fix/externalViewer/#/detail/Apps('F1873')/S7OP

Dependent OData services and reuse apps are listed there. I note that Manage Sales Orders has some reuse apps. Make sure these have been activated as well.

Also check for App Documentation links in the Fiori Apps Library - these may reveal if there are additional steps.

And as mentioned in https://blogs.sap.com/2017/01/10/leading-s4hana-ux-getting-the-good-guides/ check the Administration Guide for S/4HANA 1610 for any foundation configuration

Rgds

Jocelyn

Share
10 |10000 characters needed characters left characters exceeded
Ankur Gokhale Mar 29, 2017 at 11:37 AM
0

Hi Jocelyn, few software components were missing, after installing them (UIS4HOP1, UISAFND, UIBAS001) things started working.

We are still facing issues while loading KPIs and getting error as "Cannot load tile". We are installing SAP Analytics Foundation 1.0. Would you please let me know the path I am following is right or wrong.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Ankur,

Thanks for this info. In our system also the last two components are missing, so I will check it. Btw woould you pls tell, how did you get the hint for these missing components.

Many thanks

smriti

0

Hi Smriti,

Either few components could go missing or something to do with PFCG or app activation process one needs to carry.

0