Skip to Content

Partial results WEBI direct access to HANA VIEWS

Hi,

We have a BO 4.2 SP3. We have generated a HANA view over some DSOs directly checking the option "Generate external SAP HANA View" in the DSO in order te create WEBI reports directly over those generated HANA views.

The views are succesfully genereated and we preview the data of this views without problems in SAP HANA Studio.

The problem is that when We create the WEBI over the HANA views, We are getting the warning: "Partial results" No matter how many records are in the DSO, the WEBI won't show more than 50 pages (5.000 records).

We have already tried:

1. Checking the row limit is unchecked within the query panel in WEBI

2. We tried increasing the servers limits in the CMC

3. We have also checked the WEBI App properties within the CMC

4. Creating a HANA Calculation view over the generated HANA Analytic View

Notes:

- We do not have universes, We have the WEBI reports directly created over the HANA view so We can not check the limit within the IDT.

- When the generated view contains few data (<1000 records) We do not have the problem "Partial results".

- If we load just one field in the query panel in WEBI, the WEBI report will show 50 pages, if We add more fields into the Query panel, the number of pages displayed decrease progressively.

It clearly seems that there is some kind of limit set somewhere but We can't find the solution.

Any tip will be very appreciated,

Thanks in advance,

Juan Manuel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Mar 24, 2017 at 10:05 AM

    Check attached sap note.This is the issue in BI 4.2 SP03 with any connecitvity.

    2366194 - Refreshing a Web Intelligence report returns Partial Results after 10 minutes (600 seconds) after updating to SAP BusinessObjects Business Intelligence platform 4.2 Support Package 03

    Add comment
    10|10000 characters needed characters exceeded

    • Did anyone find an answer to this? We are seeing the same issue on 4.2 SP4. We made a copy of our HANA DB for a duel pipleline on a project and the report runs fine against the original HANA DB but gives the partial result set against the copy. Both reports run in the same BO only the backend connection is changed. Wondering if there is a setting on the HANA side that could be causing the issue?

  • avatar image
    Former Member
    Aug 18, 2017 at 11:47 AM

    Did you find an answer to this problem?

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 14 at 11:04 AM

    We had same issue . In CMC under OLAP connection there was a restriction in extended parameters option. The Maximum number of cells to fetch was only 1000 we changed it 100000 and the issue was resolved for us.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 09 at 03:50 PM

    In case anyone is still getting this issue, the solution is a setting in WEBI in Design Mode.

    Go to Data Access tab

    Under SAP HANA, there is an Options button. There you can uncheck the limitations.

    Add comment
    10|10000 characters needed characters exceeded