Skip to Content

Partial results WEBI direct access to HANA VIEWS

Mar 24, 2017 at 08:12 AM


avatar image


We have a BO 4.2 SP3. We have generated a HANA view over some DSOs directly checking the option "Generate external SAP HANA View" in the DSO in order te create WEBI reports directly over those generated HANA views.

The views are succesfully genereated and we preview the data of this views without problems in SAP HANA Studio.

The problem is that when We create the WEBI over the HANA views, We are getting the warning: "Partial results" No matter how many records are in the DSO, the WEBI won't show more than 50 pages (5.000 records).

We have already tried:

1. Checking the row limit is unchecked within the query panel in WEBI

2. We tried increasing the servers limits in the CMC

3. We have also checked the WEBI App properties within the CMC

4. Creating a HANA Calculation view over the generated HANA Analytic View


- We do not have universes, We have the WEBI reports directly created over the HANA view so We can not check the limit within the IDT.

- When the generated view contains few data (<1000 records) We do not have the problem "Partial results".

- If we load just one field in the query panel in WEBI, the WEBI report will show 50 pages, if We add more fields into the Query panel, the number of pages displayed decrease progressively.

It clearly seems that there is some kind of limit set somewhere but We can't find the solution.

Any tip will be very appreciated,

Thanks in advance,

Juan Manuel

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Mar 24, 2017 at 10:05 AM

Check attached sap note.This is the issue in BI 4.2 SP03 with any connecitvity.

2366194 - Refreshing a Web Intelligence report returns Partial Results after 10 minutes (600 seconds) after updating to SAP BusinessObjects Business Intelligence platform 4.2 Support Package 03

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Amit Kumar,

I forgot to mention we are on BI 4.2 SP03 Patch 4, so I guess this does not affect us because we are on a higher patch level.

Besides that, We don't have the "Partial results" issue with migrated reports to the new BO. It is just happening with new reports developed directly in the new BO over HANA views and the alert is not popping up after 10 minutes but earlier.

Anyway, thank you for your answer,


Juan Manuel


Did you find a solutions for this issue. We are getting same issue with partial results and we are BO 4.2 SP3 parch 3



We could not resolve this issue yet.

Does anybody know how to solve this issue?



Any solution you could find? I am facing a similar issue when migrating BO webi reports from 4.2 SP2 to 4.2 SP3 patch 6 using LCMBIAR files .

Ankur Ahuja Aug 18, 2017 at 11:47 AM

Did you find an answer to this problem?

10 |10000 characters needed characters left characters exceeded