Scheduled Analysis for Office 2.4 getting "Size limit of result set exceeded"

Hi - I am scheduling an AFO on the BI Launch Pad. I am sending the workbook via email. I am getting the message "Size limit of result set exceeded" How do I increase the limit on this size limit when it is running on the server? I know how to at the client level...

Kind regards,

Kelly

Add comment
10|10000 characters needed characters exceeded

  • Hi,

    Usually AO has 500,000 rows data display.

    You can find Ao_user_roaming_config file under this path.

    C:\Users\Userid\AppData\Roaming\SAP\Cof

    You can also change your settings HKEY_CURRENT_USER\Software\SAP\AdvancedAnalysis\Settings\

    Here are few notes from SAP on the same issue. I don't have S-Number to find the details of the Note.

    • In AO 2.x, the settings are maintained in the file system and not in the registry like in AO 1.x versions.
    • The ResultSetSizeLimit setting can be maintained in Ao_app.config (located in %PROGRAMDATA%\Sap\Cof) or Ao_user_roaming.config (located in %APPDATA%\Sap\Cof).
      • When scheduling Analysis workbooks, the ResultSetSizeLimit setting is maintained in AO_BiPrecalculation.config (located in Analysis Precalculation installation folder).
    • Please follow note 2083067 - How to maintain settings for Analysis Office 2.x to set ResultSetSizeLimit parameter.
    • The value of the ResultSetSizeLimit setting is defined as below by default:

    ResultSetSizeLimit value

    information

    <!--default: value="500000" -->
    <ResultSetSizeLimit />This is Comment Line.
    The default value for this setting is empty. It means this setting will use the default value 500000 for maximum number of cells. <ResultSetSizeLimit value="400000" />The parameter can be set to a specific number to define the maximum number of data cells with this value.
    The example is changing the ResultSetSizeLimit to 400.000 data cells. <ResultSetSizeLimit value="-1" />The parameter can be set to -1 so that the setting uses the values defined in the BW System (see section 3.2).
    In HANA there is no configuration option in backend. Hence, when using the value "-1" AO will use the default limitation of 500000.

    Thanks,

    Jothi

  • This worked - Thanks Jothi!:

    When scheduling Analysis workbooks, the ResultSetSizeLimit setting is maintained in AO_BiPrecalculation.config (located in Analysis Precalculation installation folder).

    Kind regards,

    Kelly

  • Get RSS Feed

2 Answers

  • Mar 23, 2017 at 04:46 PM

    it seems file size is more then the limit with your exchange server limit.

    other option you can try to schedule at location with File System option or at default location.in both the case users needs to pick the file from file system location or from BO.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 23, 2017 at 05:15 PM

    I am getting the email fine. The message is within my workbook. I have received email attachments much larger than the 3MB this fill takes up.

    Add comment
    10|10000 characters needed characters exceeded

Skip to Content