Skip to Content
0

Getting error Phrase Language not available for Z8 Language

Mar 23, 2017 at 02:13 PM

237

avatar image
Former Member

Hi,

After the implementation of SERC 16-05, we have got new languages into our SAP system(Z8 for example for US English). With SERC 16-05, all the phrases got updated with these new languages.

When we try to print the labels, we are getting the messages <** Phrase language not available: [ Z8 ] CUST - 100000000017326 **> on the label but when i checked in CG13, i can see the phrase with the Z8 language maintained.

I am not sure why i am getting these messages. Any help would be very much appreciated.

Thanks,

Mahidhar Suggala.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Mark Pfister
Mar 24, 2017 at 08:54 AM
0

Hello Mahidhar,

If have not yet experienced a case where WWI said the translation is missing while in fact it was there....

The phrase '100000000017326' doesn't seem to be one from SAP / CED!
Can you please send a screenshot with the phrase catalog, ID and the language Z8?

Thanks

Mark

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 24, 2017 at 12:17 PM
0

Hi Mark,

Please find the attached Z8 Language for that phrase. This issue is not just with this phrase alone but also several other phrases.


91si5.png (42.0 kB)
Share
10 |10000 characters needed characters left characters exceeded
Mark Pfister
Mar 24, 2017 at 03:43 PM
0

Hello Mahidhar,

It looks like the Z8 Translation was added on 02/042017 - correct?

Could i be, that the missing phrase error is already in the RAW Report of the label?
This is what I'm thinking:
The label report body was generated some time before 02/04/(2017?) - at a point in time where the phrase translation into language Z8 was not yet there...

Hope this helps

Mark

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Mark,

Initially i thought it was some obvious error and didn't share the complete details, but it doesn't seem like that. Let me tell you the process.

We are not getting these errors when we try with manual label printing through CBGL_MP01 but when we try with customized transaction where we are calling the Function module CBGL_TG01_TRIGGER_NAST for automatic printing, we are facing these issues with the newly added languages. Also we are getting problem with only for some random phrases, not for all even though the Z8 Language is maintained for all the phrases.

Initially we thought it was an authorization issue but we ran a trace with the custom process and found no issues with authorization. When the above Function module triggered, it will submit a background job. I am trying to debug the background job now.

The phrase was imported on 02/04/2016 as a part of 16-02 release and the WWI template was created much before and i tried regenerating(basically syntax check) that template.

Any clue would be very helpful.

Thanks,

Mahidhar.

0

Hi Mahidhar,

I guess then some of the custom coding screws things up.
It might be a language code conversion issues while translating form the external two letter code ("DE" or "Z8") to in the internal 1 letter code ("D" or ";" ) - or a lack of conversion and therefore Z8 ends up being an "Z" instead of an ";"....

Doesn't explain why the error message states Z8 and I only happens for some Z8 phrases and not all - but that's where I would start looking.

The phrase was imported on 02/04/2016 as a part of 16-02 release and the WWI template was 
created much before and i tried regenerating(basically syntax check) that template.

What happens when you create a new RAW report for one of the labels that shows the Z8 language issues during printing?


Hope this helps

Mark

0
Christoph Bergemann Jun 18, 2017 at 07:12 AM
0

Hello

You should really check feeback off Mark:

"When we try to print the labels, we are getting the messages <** Phrase language not available: [ Z8 ] CUST - 100000000017326 **> on the label but when i checked in CG13, i can see the phrase with the Z8 language maintained."

Nomally (NOT ALWAYS WITH LABELS) you create the report (raw report) and the use the report in GLM label process. If you, you should get "generation with warning" status in CG50. But of you generate the label "on the fly", then you will see the missing translation only in thre report.

If you are using "Raw" reports. just regenerate the effected reports

C.B.

Share
10 |10000 characters needed characters left characters exceeded