Skip to Content
0

Error Deleting Java Application on HCP Canary Landscape

Mar 23, 2017 at 08:28 AM

115

avatar image
Former Member

Hello,

I deployed a Java application on HCP with my dev account and some time yesterday it went into a weird state. It is shown as stopped and the java quota shows 0 of 1. But i cannot start another application, as it says my quota is at limit.

I cannot start the first application either and when i try to delete it there is an error. For a while it was 409 and now it is 500.

Has anyone had the same issue and can help me solve it?

Thank you.

Regards,
Lars

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Anton Levin
Mar 23, 2017 at 08:45 AM
0

Hello Lars, you may try to stop and delete your app using NEO Console. See this thread [1] for details.

Regards, Anton

[1] https://answers.sap.com/questions/45414/unable-to-start-or-delete-java-app-on-hcp.html?childToView=46311#answer-46311

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Anton,

thank you for your help!

I am trying to use the console, however i can't seem to connect to the internal canary landscape.

Trying a command like

neo list-runtimes -u ... - p ... -h int.sap.hana.ondemand.com

doesn't work and it says "could not connect to landscape host https://int.sap.hana.ondemand.com. Make sure your proxy settings are correct".

However, trying the same thing with host "hanatrial.ondemand.com" works.

Nevertheless i tried different proxy settings and i either get the same error or "The target server failed to respond".

Do you have any advice on how to solve this problem?

Thank you

Regards,
Lars

0

I was not able to reproduce it. It worked for me (I used "neo-java-web-sdk-2.67.13.1" SDK)

0
avatar image
Former Member
Mar 23, 2017 at 10:22 AM
0

It kind of resolved itself now.

At some point the Application went into status FAILED.

This allowed me to update it and then start it up again. Then I was able to stop finally delete it.

Share
10 |10000 characters needed characters left characters exceeded